Bug 449736

Summary: nfs rpc.mountd crashes regularly (Segmentation fault)
Product: [Fedora] Fedora Reporter: David Jansen <jansen>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 9CC: nalin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Fedora-9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-03 12:15:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Jansen 2008-06-03 05:49:59 EDT
Description of problem:
On a Fedora 9 system that exports an nfs share, rpc.mountd crashes on a sort of
regular basis. Most of the crashes are in libnss_ldap-259.so (we use LDAP for
the user database and automount maps)

Version-Release number of selected component (if applicable):
nfs-utils-1.1.2-2.fc9
nss_ldap-259-3.fc9
The problems occur both on x86_64 and on i386 systems.

How reproducible:

Steps to Reproduce:
1. Add a directory to /etc/exports and activate the nfs service. 
2. Use the exported filesystem from another computer, either through autofs or
through a manual mount command.
3. At some time it crashes, sometimes very quickly, sometimes after more than a
day, but under a heavy load, I haven't experienced a stable nfs mountd for
longer than a couple of hours

  
Actual results:
Here are the results of the last few crashes, I regularly restart the nfs
service now:

Jun  2 15:18:54 eendracht kernel: rpc.mountd[2122]: segfault at 100000005 ip
dc0922a5 sp 7fff1b09ed20 error 4 in libnss_ldap-259.so[dc058000+4b000]

Jun  2 17:10:53 eendracht kernel: rpc.mountd[17353]: segfault at 100000005 ip
f810e2a5 sp 7fff41e2b5b0 error 4 in libnss_ldap-259.so[f80d4000+4b000]

Jun  2 17:55:55 eendracht kernel: automount[31131]: segfault at 10000000b ip
576712a5 sp 405160d0 error 4 in libnss_ldap-259.so[57637000+4b000]

Jun  3 00:01:29 eendracht kernel: automount[5027]: segfault at 100000009 ip
149b52a5 sp 41cac0d0 error 4 in libnss_ldap-259.so[1497b000+4b000]

Jun  3 07:38:57 eendracht kernel: automount[24257]: segfault at 100000007 ip
8b5112a5 sp 41aa20d0 error 4 in libnss_ldap-259.so[8b4d7000+4b000]


Expected results:
a stable nfs server

Additional info:

Since we use LDAP also to serve automount maps, and the crashes occur in
libnss_ldap, I have also configured a computer without autofs, but the results
are the same (as was to be expected, since it is the server-side nfs daemon that
crashes, not the client-side mount command invoked by autofs). 
So LDAP is primarily in use to look up users and groups.

My test system now runs with SELinux disabled, to eliminate the possibility that
that is the cause of the problem, but the crashes still happen.

Settings in /etc/exports:
/data  192.168.1.0/24(rw,root_squash,sync,secure)
Comment 1 Steve Dickson 2008-06-03 07:27:08 EDT
Nalin

Any recent fixes in the nss_ldap that might have address this
problem?
Comment 2 David Jansen 2008-06-28 15:22:33 EDT
I've just reinstalled Fedora 9 (went back to 8 due to the instability). I'll
report my findings over the next couple of days.
Comment 3 Steve Dickson 2008-07-02 10:19:54 EDT
Are you still seeing this problem after the reinstall? 
Comment 4 David Jansen 2008-07-03 10:51:11 EDT
No, no more crashes since the reinstall with latest updates.