Bug 450459

Summary: exportfs reports segfault on boot up
Product: [Fedora] Fedora Reporter: Ben Webb <ben>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: dwalsh, eparis
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-18 13:53:02 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Ben Webb 2008-06-08 14:48:34 EDT
Description of problem:
Our Fedora 9 boxes (i386 and x86_64) that serve NFS do not successfully export
their NFS volumes after a reboot (clients report permission denied). An
examination of the logs reveals that exportfs is segfaulting when called from
the init scripts.

Version-Release number of selected component (if applicable):
nfs-utils-1.1.2-2.fc9 (i386 and x86_64)

How reproducible:
About 50% of reboots. The remainder of the time, exportfs appears to do its job
correctly without segfaulting.

Steps to Reproduce:
1. Reboot a Fedora 9 box that exports one or more directories.
2. Try to mount on an NFS client.
  
Actual results:
Client reports 'permission denied'. 'exportfs' run on the server prints no exports.

Expected results:
Client can mount server's NFS exports.

Additional info:
Running 'exportfs -a' manually on the server successfully exports all volumes,
every time I tried it. But obviously it's a nuisance to have to manually do this
after every reboot!

Relevant output from /var/log/messages on NFS server:
Jun  8 11:31:47 guitar kernel: exportfs[1965]: segfault at c ip 001ad11a sp
bfc5500c error 4 in libc-2.8.so[138000+163000]

BTW, this happens both on machines with SELinux enforcing and with it disabled
(the output above is from an i386 machine with it disabled).

/var/log/messages from an x86_64 machine with SELinux enforcing:
Jun  6 15:25:37 xylophone kernel: printk: 24 messages suppressed.
Jun  6 15:25:37 xylophone kernel: exportfs[1901]: segfault at 18 ip 5b78f2 sp
7fff1d893538 error 4 in libc-2.8.so[537000+162000]
Comment 4 Steve Dickson 2008-06-11 06:55:14 EDT
It would be good to figure out where in libc-2.8.so the crash
is happening... In /etc/init.d/nfs added the 'ulimit -c unlimited'
command right before the exportfs command. Hopefully that will 
let exportfs create a core and then from that core we can find 
out what is happening. 
Comment 5 Ben Webb 2008-06-14 04:31:40 EDT
Sorry - took a while to trigger the problem again (the problem does not occur on
every reboot, and so of course it doesn't happen when I'm looking for it!) But
on one of our x86_64 machines, I just got the following core:

# gdb /usr/sbin/exportfs core.2580 
...
Loaded symbols for /lib64/libnss_files-2.8.so
Core was generated by `/usr/sbin/exportfs -r'.
Program terminated with signal 11, Segmentation fault.
[New process 2580]
#0  0x00007f94b47d936e in dupexportent (dst=0x7fffbc7dd578, src=0x7fffbc7de000)
    at exports.c:320
320		*dst = *src;
(gdb) p *src
Cannot access memory at address 0x7fffbc7de000
(gdb) where
#0  0x00007f94b47d936e in dupexportent (dst=0x7fffbc7dd578, src=0x7fffbc7de000)
    at exports.c:320
#1  0x00007f94b47d7f2c in rmtab_read () at rmtab.c:45
#2  0x00007f94b47d59e2 in main (argc=2, argv=0x7fffbc7ddb88) at exportfs.c:137

Do you need anything else from this core, or is the information sufficient to
point to a problem?
Comment 6 Orion Poplawski 2008-06-18 13:53:02 EDT

*** This bug has been marked as a duplicate of 444275 ***