Bug 450810

Summary: Baekmuk Dotum slash '/' is very wide
Product: [Fedora] Fedora Reporter: Jong Bae KO <jko>
Component: baekmuk-ttf-fontsAssignee: Caius Chance <me>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: eng-i18n-bugs, fonts-bugs, petersen, sangu.fedora, smallvil
Target Milestone: ---Keywords: i18n, MoveUpstream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-02 02:04:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
screenshot none

Description Jong Bae KO 2008-06-11 03:10:00 EDT
Description of problem:
F9 Korean font on gnome-terminal is ugly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jong Bae KO 2008-06-11 03:10:00 EDT
Created attachment 308897 [details]
screenshot
Comment 2 Jong Bae KO 2008-06-11 03:10:50 EDT
'/' is the problem. too long.
Comment 3 Caius Chance 2008-06-13 01:09:19 EDT
'/' looks like a full-width glyph. Are they input barely or with SCIM?

I installed Korean Support and booted into Korean Gnome desktop. The '/' in my
gnome-terminal (default monospace font) doesn't show like the screenshot in
comment #1.
Comment 4 Caius Chance 2008-06-13 12:42:15 EDT
I found the problem glyph '/' within dotum font in baekmuk-ttf-fonts-dotum
package. It is not a compulsory font so by default baekmuk-ttf-fonts-dotum
installation is needed  to reproduce this bug.

Unfortunately, further test on such font in gnome-terminal showed it has severe
alignment problem which every glyph is frequently overlapping each other. Loaded
with fontforge to check the width of the glyphs, but the width seems correct.

Will perform more tests on other rendering platform such as OpenOffice, Pango,
etc. It might be necessary to lower this font's priority in fontconfig monospace
alias list for current workaround.
Comment 5 Nicolas Mailhot 2008-06-13 14:26:40 EDT
Our current font packaging wishlist has the following entries in it:

https://fedoraproject.org/wiki/Fonts/UN
https://fedoraproject.org/wiki/Fonts/UN_Extra

Those fonts are preferred over baekmuk for korean in the latest fontconfig
versions. Packaging them may be a better investment than changing baekmuk

(disclaimer: I don't write or read korean. I've no idea if the claims UN is
better than baekmuk are justified, and if fontconfig is right to prefer it. I
just track the fonts wishlist)
Comment 6 Caius Chance 2008-06-16 18:35:42 EDT
True, Nicolas. There are way width problem on many glyphs in dotum. We should
not keep that as default monospace font at the moment.
Comment 8 Jens Petersen 2008-06-23 00:06:09 EDT
Yes, we are planning to include un-fonts in F10.
Comment 9 Jens Petersen 2008-07-01 21:32:44 EDT
Un Dotum does not seem to have this problem btw.
Comment 10 Caius Chance 2008-07-02 19:28:56 EDT
Patch of openoffice to change requires from fonts-korean to baekmuk-ttf-fonts
rely on this bug. OO has to be patched again when default Korean font is
changed. (bug#453868)
Comment 11 Jens Petersen 2008-07-08 02:01:22 EDT
Maybe you can ask about the / issue upstream
Comment 12 Caius Chance 2008-08-06 01:46:57 EDT
Emailed upstream about the problem of dotum:

http://kldp.net/projects/baekmuk/
Comment 13 Caius Chance 2008-09-02 02:04:14 EDT
According to jensp, dotum is not default font for Korean locale now.

Also, still waiting for un-core-fonts to be built.

Closing this bug.