Bug 451829

Summary: qemu-kvm hangs/stalls if executed by non-root
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: kvmAssignee: Glauber Costa <gcosta>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: berrange, clalance, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-20 12:05:21 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Output of "strace qemu-kvm -localtime -m 512 -std-vga raw.img" none

Description Tom London 2008-06-17 13:34:27 EDT
Description of problem:
"qemu-kvm" stalls/hangs on startup if I execute it as non-root.

Works fine if I run as root.

I have tried this both with SELinux in enforcing and permissive mode: no joy.

I attach the output of "strace qemu-kvm -localtime -m 512 -std-vga raw.img"

Version-Release number of selected component (if applicable):
kvm-69-1.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-06-17 13:34:27 EDT
Created attachment 309642 [details]
Output of "strace qemu-kvm -localtime -m 512 -std-vga raw.img"
Comment 2 Glauber Costa 2008-06-18 09:37:15 EDT
Yesterday, I've upgraded kvm to kvm-70.
Could you please upgrade and see if this problem got fixed by any of upstream
commit?
By looking at the commit list, I very honestly don't think so. But let us try to
focus on the topmost thing here ;-)

In case the problem persists, can you provide us with some more info, like dmesg
messages, if any suspicious, and host information? 
Comment 3 Tom London 2008-06-18 09:51:15 EDT
Nope.  Fails with the same strace.  Here are the last few lines:

read(6,
"\1\0001\0\5\0\0\0\22\0\320\10\0\0\0\0\10\0\0\0\0\0\0\0\20o\320\10\0\0\0\0"...,
4096) = 52
read(6, 0x9ad3ffc, 4096)                = -1 EAGAIN (Resource temporarily
unavailable)
select(7, [6], [6], NULL, NULL)         = 1 (out [6])
writev(6, [{"\20\1\4\0\7\0\0\0LOCALES\0", 16}], 1) = 16
select(7, [6], [], NULL, NULL)          = 1 (in [6])
read(6, "\1\0002\0\0\0\0\0k\1\0\0\0\0\0\0\20\0\0\0\0\0\0\0\20o\320\10\0\0\0\0",
4096) = 32
read(6, 0x9ad3ffc, 4096)                = -1 EAGAIN (Resource temporarily
unavailable)
select(7, [6], [6], NULL, NULL)         = 1 (out [6])
writev(6, [{"\30\1\6\0\4\0\0\4q\1\0\0k\1\0\0k\1\0\0\0\0\0\0", 24}], 1) = 24
select(7, [6], [], NULL, NULL


This worked as late as last Thursday, so I'm guessing its due to an update since
then.

I'll try to strace qemu-kvm running as root and see if I can see anything in the
"diff".

There is nothing in /var/log/messages that I can see.

Running on Thinkpad X60, latest rawhide, kernel-2.6.26-0.74.rc6.git4.fc10.i686
Comment 4 Tom London 2008-06-18 10:03:59 EDT
Mysterious..... after today's rawhide updates, and some fiddling with nscd, this
started working.

Let me probe on this for a day or so.  If it no longer fails, I'll close this BZ.

Comment 5 Glauber Costa 2008-06-18 10:58:02 EDT
So it's probably related to some other issue, on another package. Last kvm
update (excluding yesterday one), was done much earlier than last tuesday.
Comment 6 Tom London 2008-06-20 12:05:21 EDT
I can no longer reproduce this; must be ghosts ;)

Closing as NOTABUG