Bug 454939

Summary: Mouse freezes while sound is jittering on Dell Latitude D630 Laptop
Product: [Fedora] Fedora Reporter: Scott Dowdle <dowdle>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-12 16:08:10 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Scott Dowdle 2008-07-10 17:43:55 EDT
Problem: Sound will occasionally jitter/stutter for periods of say... 20 seconds
or so.  While that is happening the mouse pointer will freeze.  The mouse
pointer unfreezes once the stuck sound becomes normal again.  Just to clarify,
say the sound is "a".  Rather than just "a" I hear "a a a a a a a a a" like it
is scratched and repeating itself.  It doesn't seem to matter how long the sound
plays for... it can be the GNOME startup sound (which is short) or two minutes
into a Prince's 1999.

There are some times where there is no (obvious) sound output and the mouse
pointer will not be visible until after 10 seconds of moving the mouse around.

I don't know if the mouse the issue and the sound issue are related to another
or not but they appear to be.

All other hardware works great including the wired and wireless network
adaptors, the display (1440 x 900 widescreen), accellerated video (although I
leave Desktop Effects turned off), special keys on the keyboard (screen
brightness, volume control, the wireless NIC on/off switch)... I can even plug
in an external display and open up the Screen Resolution tool and detect it and
use it.  Everything works great accept for the periodic stuttering sound and mouse.

Kernel version: kernel-2.6.25.9-76.fc9.x86_64

Hardware: lspci output:

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory
Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated
Graphics Controller (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2
(rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE
Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
03:01.0 CardBus bridge: O2 Micro, Inc. Cardbus bridge (rev 21)
03:01.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5755M Gigabit
Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)

I'll check out the 2.6.9.10 kernel whenever it is released and close this bug if
it goes away.  If there is any troubleshooting you want me to do, please let me
know what and I'll update this report.  I hope it is complete enough.
Comment 1 Scott Dowdle 2008-07-10 17:52:00 EDT
Just to clarify, I have rebooted/cycled power several times since initially
noticing this bug and it is immediate upon login and reproduceable every time.
Comment 2 Scott Dowdle 2008-08-12 22:48:13 EDT
I have installed every kernel update since I originally filed this bug report and am currently on kernel-2.6.25.14-108.fc9.x86_64.  I am still having the jitter problem.

Oddly enough, simply unplugging the laptop from power or plugging it in can cause it to jitter.

Any suggestions on how to troubleshoot this problem?
Comment 3 Scott Dowdle 2008-09-12 16:08:10 EDT
I'm closing this bug... as I have discovered it only manifest itself for me in GNOME.  I'm a long time KDE user but I was waiting for KDE 4.1 to be released... and it was released / updated in Fedora 9 updates recently... so I installed it and switched to it and the stuttering totally went away.  I could actually play multiple audio/video sources and have no issues at all.  If I switch back to GNOME, the issue come back.

I thought it was a kernel issue but it is somehow related to GNOME or a GNOME library... and I have no idea which or what to even check for.  If someone can give me some idea what package to refile this bug under, I'll be happy to do so... but not knowing means I'll just close this one for now.