Bug 455228

Summary: scim doesn't start in Fedora 9 with icewm as window manager
Product: [Fedora] Fedora Reporter: Daniil Ivanov <daniil.ivanov>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 10CC: i18n-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-10 06:42:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Daniil Ivanov 2008-07-14 04:31:46 EDT
Description of problem:

After ugrade from Fedora 8 to Fedora 9 scim failed to run.

Additional info:
I'm using icewm as my window manager.
To make scim work under icewm I had to do following changes to
imsettings:
1. comment out unset for GTK_IM_MODULE as it was not restored from GConf.
2. Essentially I've faced bug 448268 (I don't really care about 32-bit
  applications, but I want it to work in my 64-bit environment).
3. Also I've faced bug 250226 as I'm Cyrillic user using scim for typing
   in Ukrainian and Russian and having English as language of my system.
4. Scim was failing on start so I had to add
   XIM_ARGS="-f socket -d"
Comment 1 Daniil Ivanov 2008-07-16 03:29:55 EDT
Additional comment:
using ~/.xinputrc actually helps to avoid problems described in items 2-3. But
not with unsetting GTK_IM_MODULE.
Comment 2 Akira TAGOH 2008-07-24 04:43:28 EDT
Well, 2 and 4 isn't actually imsettings bug. but scim maybe. please file a
separate bug for that.

1 will be fixed in next release. I'm not sure how Russian and Ukrainian people
input their native language though, is it a good idea to bring up scim say by
default?
Comment 3 Akira TAGOH 2008-07-29 07:17:33 EDT
Anyway, imsettings-0.102.0-1 works for even icewm now.
Comment 4 Daniil Ivanov 2008-07-31 04:24:14 EDT
Thanks for fixing!

I disagree that 2 (bug 448268) is not imsetting bug. I believe scim
should be activated, if at least one of scim versions is installed.

Not all Ukrainians and Russians are using scim as some of them
are using native keyboard layouts. If you really want to start
scim conditionally, instead of language of the system, I believe,
better choice is to check installed scim-tables:
scim-tables-additional, scim-tables-amharic etc.
and 
m17n-db-amharic, m17n-db-arabic etc. (with presence of scim-m17n).
They are not installed by default, and if somebody adds some tables,
this is good indicator for launching scim.
Comment 5 Akira TAGOH 2008-07-31 04:49:08 EDT
(In reply to comment #4)
> Thanks for fixing!
> 
> I disagree that 2 (bug 448268) is not imsetting bug. I believe scim
> should be activated, if at least one of scim versions is installed.

Actually which immodules IM wants to use is up to the script IM itself provided.
imsettings just follows what they request. see /etc/X11/xinit/xinput.d/scim.conf
for more details what they do for multilib.

> Not all Ukrainians and Russians are using scim as some of them
> are using native keyboard layouts. If you really want to start
> scim conditionally, instead of language of the system, I believe,
> better choice is to check installed scim-tables:
> scim-tables-additional, scim-tables-amharic etc.
> and 
> m17n-db-amharic, m17n-db-arabic etc. (with presence of scim-m17n).
> They are not installed by default, and if somebody adds some tables,
> this is good indicator for launching scim.

As you may be aware of that, we have a hard-coded locale list in
/etc/X11/xinit/xinitrc.d/50-xinput.sh to default IM running, because people
doesn't want to see IM on some locales. so actually what I wanted to know is,
how does the majority of people input their native language. if it's IM like
scim, that would be worth adding ru and uk to the hard-coded locale list in
50-xinput.sh.
Comment 6 Daniil Ivanov 2008-07-31 06:45:35 EDT
(In reply to comment #5)
> Actually which immodules IM wants to use is up to the script IM itself provided.
> imsettings just follows what they request. see /etc/X11/xinit/xinput.d/scim.conf
> for more details what they do for multilib.

Sorry, I missed that scim.conf belongs to scim package.
 
> As you may be aware of that, we have a hard-coded locale list in
> /etc/X11/xinit/xinitrc.d/50-xinput.sh to default IM running, because people
> doesn't want to see IM on some locales. so actually what I wanted to know is,
> how does the majority of people input their native language. if it's IM like
> scim, that would be worth adding ru and uk to the hard-coded locale list in
> 50-xinput.sh.
> 
I do not pretend for being statistically correct, but I've noted that people
using English as the system language tend to use scim, while people, using
Russian or Ukrainian as the system language tend to use national keyboard layout
instead of scim. There is no sense to add ru and uk to the list.
Also that means that hardcoded list will never work for people,
using English as system language as mentioned in bug 250226. That's why I
believe that list have to be replaced with check for installed tables.
Comment 7 Akira TAGOH 2008-07-31 08:32:14 EDT
(In reply to comment #6)
> I do not pretend for being statistically correct, but I've noted that people
> using English as the system language tend to use scim, while people, using
> Russian or Ukrainian as the system language tend to use national keyboard layout
> instead of scim. There is no sense to add ru and uk to the list.
> Also that means that hardcoded list will never work for people,
> using English as system language as mentioned in bug 250226. That's why I
> believe that list have to be replaced with check for installed tables.

Thanks for the info. I'm afraid I won't make any kind of hack in xinput.sh much
more. AFAICT people who use English as the system language, just needs to turn
on the check box on im-chooser to enable IM feature then. that would be sane for
Live CD too.
Comment 8 Tony Fu 2008-09-09 23:18:38 EDT
requested by Jens Petersen (#27995)
Comment 9 Bug Zapper 2008-11-25 21:33:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping