Bug 457870

Summary: mkinitrd does not respect module command line options set in /etc/modprobe.d/
Product: [Fedora] Fedora Reporter: Robert Hancock <hancockrwd>
Component: mkinitrdAssignee: Peter Jones <pjones>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 11CC: daw-redhatbugzilla, dcantrell, gerd, wtogami
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-30 01:20:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert Hancock 2008-08-05 04:48:36 UTC
Description of problem:
mkinitrd only looks for /etc/modprobe.conf when looking for module command-line options for the modules it loads. Fedora 9 is now storing modprobe configuration in separate files in /etc/modprobe.d but mkinitrd does not look in this location.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.52-2.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Add a module option to a new file in /etc/modprobe.d, for example:

options sata_nv adma=1


2. Run mkinitrd

3. Dump the contents of the initrd and check for any /etc/modprobe.conf file - there is none
  
Actual results:

No /etc/modprobe.conf file.

Expected results:

Options from /etc/modprobe.d are either copied into the initrd as-is or extracted into a modprobe.conf file.

Additional info:

This makes it impossible for the user to specify command-line options for kernel modules loaded in the initrd.

Comment 1 Robert Hancock 2008-12-14 22:28:54 UTC
This is still a problem in Fedora 10.

Comment 2 D. Wagner 2009-01-18 00:44:28 UTC
In case it matters, I'll add my vote for fixing this.  Like many modern desktops, my machine uses SATA drives; in Fedora kernels, libata is loaded as a kernel module (by initrd), not built into the kernel; so options for libata that are listed in /etc/modprobe.d are ignored right now.

Comment 3 Robert Hancock 2009-06-12 05:02:11 UTC
Appears to still be a problem in Fedora 11 (mkinitrd-6.0.86-2.fc11).

Comment 4 Robert Hancock 2009-11-23 04:59:42 UTC
Dracut in Fedora 12 doesn't seem to have this problem from inspecting the code anyway, it looks like all the /etc/modprobe.d files get dumped into the initrd.

Comment 5 Robert Hancock 2009-11-30 01:20:49 UTC
Appears fixed in Fedora 12.