Bug 458719

Summary: panel goes nuts when update-desktop-database runs
Product: [Fedora] Fedora Reporter: Jeremy Katz <katzj>
Component: gnome-panelAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: caiqian, mclasen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-13 01:09:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 457945    

Description Jeremy Katz 2008-08-11 16:38:51 EDT
When update-desktop-database runs (eg, in %post of a package installing), the panel goes a bit nuts and then restarts.  This looks ... less than good
Comment 1 Matthias Clasen 2008-08-11 18:02:03 EDT
How exactly does it flip out ?

Any chance you could get me a stacktrace ?

No luck reproducing this so far.
Comment 2 Jeremy Katz 2008-08-11 18:57:01 EDT
Panel goes away, then comes back.  Looking closer, it is segfaulting based on teh message in dmesg.  I've seen it happen now a few times i nthe past week or so.

After debuginfo-install'ing, it of course took me a few more times, but I finally triggered it

(gdb) thread apply all bt
Thread 2 (Thread 0xb2e92b90 (LWP 20526)):
#0  0x00132416 in __kernel_vsyscall ()
#1  0x0106a7f7 in __poll (fds=0x8c9e450, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x049ec202 in ?? () from /usr/lib/libpulse.so.0
#3  0x049dacf9 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0x049dc4d3 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0x049dc5a4 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0x049ebfb3 in ?? () from /usr/lib/libpulse.so.0
#7  0x04a14477 in ?? () from /usr/lib/libpulse.so.0
#8  0x00f7d51f in start_thread (arg=0xb2e92b90) at pthread_create.c:297
#9  0x010750ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb8071760 (LWP 20516)):
#0  IA__g_type_check_instance_cast (type_instance=0x8e8da88, 
    iface_type=145577184) at gtype.c:3728
#1  0x005ea318 in real_queue_resize (widget=0x8e8daf0) at gtksizegroup.c:159
#2  0x005ea45f in queue_resize_on_widget (widget=0x8e8daf0, check_siblings=1)
    at gtksizegroup.c:203
#3  0x005eb88c in _gtk_size_group_queue_resize (widget=0x8e8daf0)
    at gtksizegroup.c:838
#4  0x006cd9b0 in IA__gtk_widget_queue_resize (widget=0x8e8daf0)
    at gtkwidget.c:3611
#5  0x00539dc2 in gtk_image_update_size (image=0x8e8daf0, image_width=0, 
    image_height=0) at gtkimage.c:2261
#6  0x005399b3 in IA__gtk_image_clear (image=0x8e8daf0) at gtkimage.c:2153
#7  0x0053701f in IA__gtk_image_set_from_pixbuf (image=0x8e8daf0, pixbuf=0x0)
    at gtkimage.c:923
#8  0x0807e249 in reload_image_menu_items () at menu.c:249
#9  icon_theme_changed (icon_theme=0x8b63088, data=0x0) at menu.c:261
#10 0x00d630e4 in IA__g_cclosure_marshal_VOID__VOID (closure=0x8c988b0, 
    return_value=0x0, n_param_values=1, param_values=0x8e3e048, 
    invocation_hint=0xbf8a009c, marshal_data=0x807e210) at gmarshal.c:77
#11 0x00d551f3 in IA__g_closure_invoke (closure=0x8c988b0, return_value=0x0, 
    n_param_values=1, param_values=0x8e3e048, invocation_hint=0xbf8a009c)
    at gclosure.c:767
#12 0x00d6ca45 in signal_emit_unlocked_R (node=0x8c1df30, detail=0, 
    instance=0x8b63088, emission_return=0x0, instance_and_params=0x8e3e048)
    at gsignal.c:3244
#13 0x00d6e166 in IA__g_signal_emit_valist (instance=0x8b63088, signal_id=219, 
    detail=0, var_args=0xbf8a023c "|��") at gsignal.c:2977
#14 0x00d6e616 in IA__g_signal_emit (instance=0x8b63088, signal_id=219, 
    detail=0) at gsignal.c:3034
#15 0x0051d551 in ensure_valid_themes (icon_theme=0x8b63088)
    at gtkicontheme.c:1215
#16 0x00520f95 in _gtk_icon_theme_check_reload (display=0x8abf0c0)
    at gtkicontheme.c:3400
#17 0x006e62bd in gtk_window_client_event (widget=0x8b1d1b8, event=0x8ac1778)
    at gtkwindow.c:5171
#18 0x0055bbfd in _gtk_marshal_BOOLEAN__BOXED (closure=0x8ad9f28, 
    return_value=0xbf8a04b0, n_param_values=2, param_values=0x8c48e00, 
    invocation_hint=0xbf8a049c, marshal_data=0x6e6201) at gtkmarshalers.c:84
#19 0x00d53969 in g_type_class_meta_marshal (closure=0x8ad9f28, 
    return_value=0xbf8a04b0, n_param_values=2, param_values=0x8c48e00, 
    invocation_hint=0xbf8a049c, marshal_data=0x10c) at gclosure.c:878
#20 0x00d551f3 in IA__g_closure_invoke (closure=0x8ad9f28, 
    return_value=0xbf8a04b0, n_param_values=2, param_values=0x8c48e00, 
    invocation_hint=0xbf8a049c) at gclosure.c:767
#21 0x00d6c6cd in signal_emit_unlocked_R (node=0x8ad9f78, detail=0, 
    instance=0x8b1d1b8, emission_return=0xbf8a05e8, 
    instance_and_params=0x8c48e00) at gsignal.c:3282
#22 0x00d6e00b in IA__g_signal_emit_valist (instance=0x8b1d1b8, signal_id=72, 
    detail=0, var_args=0xbf8a0640 "\\\006\212�\035") at gsignal.c:2987
#23 0x00d6e616 in IA__g_signal_emit (instance=0x8b1d1b8, signal_id=72, 
    detail=0) at gsignal.c:3034
#24 0x006cfd99 in gtk_widget_event_internal (widget=0x8b1d1b8, event=0x8ac1778)
    at gtkwidget.c:4745
#25 0x006cf893 in IA__gtk_widget_event (widget=0x8b1d1b8, event=0x8ac1778)
    at gtkwidget.c:4542
#26 0x00558724 in IA__gtk_main_do_event (event=0x8ac1778) at gtkmain.c:1546
#27 0x009f62d3 in gdk_event_dispatch (source=0x8ac4080, callback=0, 
    user_data=0x0) at gdkevents-x11.c:2365
#28 0x00dc6381 in g_main_dispatch () at gmain.c:2072
#29 IA__g_main_context_dispatch (context=0x8ac40c8) at gmain.c:2624
#30 0x00dc9a23 in g_main_context_iterate (context=0x8ac40c8, block=1, 
    dispatch=1, self=0x8a9d5a0) at gmain.c:2705
#31 0x00dc9f42 in IA__g_main_loop_run (loop=0x8c971d0) at gmain.c:2928
#32 0x00557e55 in IA__gtk_main () at gtkmain.c:1172
#33 0x080609a4 in main (argc=1, argv=0xbf8a0964) at main.c:102
Comment 3 Matthias Clasen 2008-08-12 15:26:35 EDT
Upstream bug is http://bugzilla.gnome.org/show_bug.cgi?id=546756
Comment 4 Matthias Clasen 2008-08-13 00:40:18 EDT
*** Bug 456744 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Clasen 2008-08-13 01:09:06 EDT
Should be fixed in gtk2-2.13.6-4.fc10