This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 458864

Summary: RANDR 1.2 drivers should allocate enough memory that resizing works sensibly
Product: [Fedora] Fedora Reporter: Adam Jackson <ajax>
Component: xorg-x11-serverAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: mcepl
Target Milestone: ---Flags: ajax: fedora_requires_release_note+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-08 16:02:11 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 457945    

Description Adam Jackson 2008-08-12 14:46:25 EDT
This is more a "note to self" than anything, just want to get it on my radar for F10.
Comment 1 Adam Jackson 2008-09-08 16:02:11 EDT
Right, committed for Radeon, nVidia G80, and Intel drivers.

The behaviour here is subtle and should be documented in the release notes.  Something like the following:

---

The radeon, nv, and intel drivers will now attempt to allocate sufficient memory to enable display hotplugging to just work in more situations.  If your graphics card has more than 64M of video memory, the driver will preallocate enough space for two 1920x1200 displays set side by side.  It is not possible to do this automatically for 64M and smaller cards without impacting 3D functionality.  Also note that this does not apply to nVidia cards older than the GeForce 7 series due to software limitations, or to Intel chips older than the 965 series due to hardware limitations.

---

This may still be subject to change before release, as a working memory manager makes this moot.