Bug 459048

Summary: update dmidecode from 2.7 to 2.9, the latest version
Product: Red Hat Enterprise Linux 5 Reporter: Jim <james.weinert>
Component: dmidecodeAssignee: Jarod Wilson <jarod>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.3CC: cward, dkovalsk, dmair, duck, jarod, jnansi, karen.skweres, martinez, msusta, peterm, riek, rpacheco, sandy.garza, tao
Target Milestone: ---Keywords: Rebase
Target Release: ---Flags: rpacheco: needinfo? (james.weinert)
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
-Updated support for SMBIOS specification version 2.5 -Decoding of slot ID of AGP 8x and PCIE slots -Decoding of newer processor characteristics (multi-core, multi-thread, 64-bit) -Updated chassis, processor, socket, connector and memory device type support -Added x86 EFI support
Story Points: ---
Clone Of:
: 518562 (view as bug list) Environment:
Last Closed: 2009-09-02 06:04:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dmidecode 2.1
none
dmidecode 2.7 none

Description Jim 2008-08-13 17:54:03 EDT
Red Hat 4.7 ships with dmidecode 2.2 which does not have entries for DDR3 Memory sticks used in the upcoming HP G6 servers. The Memory entries will show "<OUT OF SPEC>" as their type. This problem is fixed by updating to dmidecode 2.9 which also adheres to the latest SMBIOS specification.
Comment 1 Jarod Wilson 2008-08-13 23:26:19 EDT
kernel-utils doesn't exist in RHEL5, reassigning to proper component.
Comment 2 Alan Cox 2008-08-14 04:50:19 EDT
This bug report is about RHEL4 not RHEL5... putting it back
Comment 3 Jarod Wilson 2008-08-14 10:06:31 EDT
Alan, despite the initial description, I'm pretty sure this is supposed to be a RHEL5 bug -- there was a matching bug definitely for RHEL4 filed about the same time (bug 459041). Jim, can you please clarify?
Comment 4 Jim 2008-08-14 10:55:45 EDT
Yes, this should be for RHEL5.
Comment 5 Sandy Garza 2008-08-14 11:08:23 EDT
This is to be written for RHEL5. The corresponding Bugzilla for RHEL 4 is 459041.
Comment 6 Jarod Wilson 2008-08-14 11:22:58 EDT
Flipping bits again... :)
Comment 9 Daniel Riek 2008-08-19 23:04:22 EDT
We don't have a QE component slot available, so this is not going to make 5.3. Proposing for 5.4.
Comment 21 Jarod Wilson 2009-06-26 10:55:47 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
-Updated support for SMBIOS specification version 2.5
-Decoding of slot ID of AGP 8x and PCIE slots
-Decoding of newer processor characteristics (multi-core, multi-thread, 64-bit)
-Updated chassis, processor, socket, connector and memory device type support
-Added x86 EFI support
Comment 22 Chris Ward 2009-07-03 14:06:15 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 23 Sandy Garza 2009-07-22 22:50:51 EDT
This has been successfully verified by HP with RHEL 5.4.
Comment 26 Sandy Garza 2009-08-20 10:56:53 EDT
HP retested this issue with RHEL 5.4 snapshot 5 and there was an <OUT OF SPEC> on the PCI-E slot information.  ==> Test result is FAILED.

Configuration :
DL360 G6 / 0724_09 BIOS
PCI-E slot 1 : NC373
PCI-E slot 2 : NC364

Handle 0x0901, DMI type 9, 17 bytes
System Slot Information
        Designation: PCI-E Slot 1
        Type: x8 <OUT OF SPEC>
        Current Usage: In Use
        Length: Long
        Characteristics:
                3.3 V is provided
                PME signal is supported

Handle 0x0902, DMI type 9, 17 bytes
System Slot Information
        Designation: PCI-E Slot 2
        Type: x16 <OUT OF SPEC>
        Current Usage: In Use
        Length: Long
        Characteristics:
                3.3 V is provided
                PME signal is supported
Comment 27 Jarod Wilson 2009-08-20 16:11:22 EDT
(In reply to comment #26)
> HP retested this issue with RHEL 5.4 snapshot 5 and there was an <OUT OF SPEC>
> on the PCI-E slot information.  ==> Test result is FAILED.
> 
> Configuration :
> DL360 G6 / 0724_09 BIOS
> PCI-E slot 1 : NC373
> PCI-E slot 2 : NC364

A few questions...

1) is this the same hardware on which the update was verified in comment #23?

2) is this a regression from the prior dmidecode shipped in RHEL5.3 (dmidecode 2.7)?

3) does the latest upstream release (dmidecode 2.10) work?

I'll try to find a similar machine internally here to test on myself...
Comment 28 Sandy Garza 2009-08-20 16:35:17 EDT
I will gather response to your questions 2 and 3. Regarding question, we did a verification of the dmidecode version and did not validate the test from Comment #26 until RHEL 5.4 reached a late state (Snapshot 5).
Comment 29 Jarod Wilson 2009-08-20 17:40:08 EDT
I managed to get onto a DL360 G6 here in our lab, and verified the same issue exists with dmidecode 2.9 on it. In addition to not fully identifying the PCI-E slot info, it also failed on the processor Family field.

I've also now run dmidecode 2.10 on it, and while it remedies the processor Family field, it still reports the same <OUT OF SPEC> information for the PCI-E slots.
Comment 30 Jarod Wilson 2009-08-20 18:30:36 EDT
So the original issue reported here, DDR3 memory not being reported correctly, seems to be resolved, so what we'd like to do is address the remaining issues in another bug. I've cloned this bug over to bug 518562 for this purpose.
Comment 31 Sandy Garza 2009-08-21 10:09:40 EDT
(In reply to comment #27)
> (In reply to comment #26)
> > HP retested this issue with RHEL 5.4 snapshot 5 and there was an <OUT OF SPEC>
> > on the PCI-E slot information.  ==> Test result is FAILED.
> > 
> > Configuration :
> > DL360 G6 / 0724_09 BIOS
> > PCI-E slot 1 : NC373
> > PCI-E slot 2 : NC364
> A few questions...
> 1) is this the same hardware on which the update was verified in comment #23?
> 2) is this a regression from the prior dmidecode shipped in RHEL5.3 (dmidecode
> 2.7)?
> 3) does the latest upstream release (dmidecode 2.10) work?
> I'll try to find a similar machine internally here to test on myself...  

Responses to 2 and 3:
1) Is this a regression from the prior dmidecode shipped in RHEL5.3 (dmidecode 2.7)? 
   =>RHEL 5.3 (dmidecode 2.7) is still failing.

2) Does the latest upstream release (dmidecode 2.10) work?  
   =>RHEL 5.3 (dmidecode 2.10) is still failing.
Logs attached
Comment 32 Sandy Garza 2009-08-21 10:10:24 EDT
Created attachment 358249 [details]
dmidecode 2.1
Comment 33 Sandy Garza 2009-08-21 10:10:44 EDT
Created attachment 358250 [details]
dmidecode 2.7
Comment 34 Ronald Pacheco 2009-08-21 17:56:06 EDT
Sandy,

As noted in Comment #30, the original problem report has been resolved.  Please open a new BZ for the new problem and the attachments you just added.
Comment 35 Jarod Wilson 2009-08-21 18:30:06 EDT
(In reply to comment #34)
> Sandy,
> 
> As noted in Comment #30, the original problem report has been resolved.  Please
> open a new BZ for the new problem and the attachments you just added.  

See comment #30 -- I've already opened bug 518562 to track this part.
Comment 36 Jarod Wilson 2009-08-24 16:36:13 EDT
(In reply to comment #30)
> So the original issue reported here, DDR3 memory not being reported correctly,
> seems to be resolved, so what we'd like to do is address the remaining issues
> in another bug.

Of course, I should look closer at the output on this system. Its actually *not* reporting DDR3 memory correctly either. Good news is that I'm getting up to speed on the dmidecode source fairly quickly, and I've actually got the dl360 g6 here reporting its pcie slot types and socket type correctly now...
Comment 37 errata-xmlrpc 2009-09-02 06:04:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1324.html