Bug 459518

Summary: STIR4210 TA4, STIR4210/4220/4116 TA5 firmware
Product: [Fedora] Fedora Reporter: acount closed by user <a1459440>
Component: distributionAssignee: Bill Nottingham <notting>
Status: CLOSED WONTFIX QA Contact: Bill Nottingham <notting>
Severity: low Docs Contact:
Priority: medium    
Version: 10CC: dcantrell, katzj, rvokal, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://www.sigmatel.com/support/developer/downloads.aspx
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-12-11 14:42:14 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 182235    

Description acount closed by user 2008-08-19 12:23:01 EDT
---cut---
http://www.sigmatel.com/documents/stir4210_4220_4116_patch_files.tar.gz

The file contains Firmware Patches for the STIR4210 TA4 and the STIR4210/4220/4116 TA5. This patch is required for normal operation of the Linux Driver.
Most Linux distributions don’t include any built-in mechanism to transfer files over an IrDA link, as they include a full-feature IrDA stack, but not the application that uses the stack to perform file transfers. In order to enable such functionality the “ircp” package can be used. This allows file transfers to/from Linux, Windows, PDAs and other devices that use the OBEX protocol. Because the “ircp” application doesn’t take advantage of IrDA features allowing high-speed transfers, effective transfer rates may be slower than in other operating systems. There may be other IrDA software available that can take advantage of the higher transfer rates that are supported by the device and the posted driver.
---end---

put it at /lib/firmware/ , otherwise the hardware does not work.

more info at : drivers/net/irda/irda-usb.c

-thanks-
Comment 1 Bill Nottingham 2008-08-20 20:24:15 EDT
Are you voulunteering to maintain this package?
Comment 2 acount closed by user 2008-09-15 05:54:49 EDT
asked to support@sigmatel.com about the license.
Comment 3 acount closed by user 2008-11-20 18:02:15 EST
It looks like Sigmatel was bought by Freescale.

"McKissick Rebecca" <lmckissick@freescale.com> says:

--cut--
No license is required- but as stated  before, these parts are no longer
available, nor in the information at that website.
--end--

next step ?
Comment 4 Bug Zapper 2008-11-25 21:49:22 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bill Nottingham 2008-12-01 15:24:30 EST
'No license is required'? CC'ing FE-LEGAL, but I don't think that's enough of a disclaimer for us to ship.
Comment 6 Tom "spot" Callaway 2008-12-01 15:30:27 EST
Yeah, we need license terms for this firmware.
Comment 7 acount closed by user 2008-12-11 14:42:14 EST
(In reply to comment #6)

> Yeah, we need license terms for this firmware.

There is NO license and freescale(was sigmatel) said:

"I am sorry, but this is not possible."

to my request:

I would like a license like this, or similar. Is it possible ??
(replace XXXXXXXXXXXXXXXXXXXXXX with SIGMATEL and
YYYYYYYYYYYYYYYYYYYYYYYYYY with the hardware device)


----top license----
Copyright (c)  2008 XXXXXXXXXXXXXXXXXXXXXX Corporation
YYYYYYYYYYYYYYYYYYYYYYYYYY Firmware

You may redistribute the hardware specific firmware binary file under
the following terms:

         1. Redistribution of source code (only if applicable),
            must retain the above copyright notice, this list of
            conditions and the following disclaimer.

         2. Redistribution in binary form must reproduce the above
            copyright notice, this list of conditions and the
            following disclaimer in the documentation and/or other
            materials provided with the distribution.

         3. The name of XXXXXXXXXXXXXXXXXXXXXX may not be used to
            endorse or promote products derived from this software
            without specific prior written permission

REGARDLESS OF WHAT LICENSING MECHANISM IS USED OR APPLICABLE, THIS
PROGRAM IS PROVIDED BY XXXXXXXXXXXXXXXXXXXXXX CORPORATION "AS IS'' AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

USER ACKNOWLEDGES AND AGREES THAT USE OF THIS PROGRAM WILL NOT CREATE OR
GIVE GROUNDS FOR A LICENSE BY IMPLICATION, ESTOPPEL, OR OTHERWISE IN ANY
INTELLECTUAL PROPERTY RIGHTS (PATENT, COPYRIGHT, TRADE SECRET, MASK
WORK, OR OTHER PROPRIETARY RIGHT) EMBODIED IN ANY OTHER
XXXXXXXXXXXXXXXXXXXXXX HARDWARE OR SOFTWARE EITHER SOLELY OR IN
COMBINATION WITH THIS PROGRAM.
----end license----

they are similar as Qlogic does with its Linux firmware:
ftp://ftp.qlogic.com/outgoing/linux/firmware/LICENSE


In Open Source we are very strict about Copyright holders.

But if you _insists_ that it is not necesary, I will put a file with
this mail into the distribucion.

==========================================================================


If Fedora Legal want to try it talk with McKissick Rebecca <lmckissick@freescale.com>

Now, I am going to close this bug.

-thanks-