This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 460197

Summary: install driver script and desktop file
Product: [Fedora] Fedora Reporter: jmccann
Component: compizAssignee: Kristian Høgsberg <krh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: cschalle, dcantrell, krh, mclasen, otaylor
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-25 19:53:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 457945    

Description jmccann 2008-08-26 14:39:39 EDT
Description of problem:
With gnome-session 2.23 we have deprecated the gnome-wm script in favor of having WMs install desktop files and change the /desktop/gnome/session/required-components/windowmanager gconf key.

Since compiz must be started in a very specific way to be useful, we should install a driver script by default.  Previously, gnome-wm had been the de-facto driver script.

I propose that we call this script compiz-gtk.  We should install a corresponding desktop file into the XDG application dirs for it.


Some parts of compiz-manager may be able to be used for this new script... http://gitweb.compiz-fusion.org/?p=fusion/misc/compiz-manager;a=tree
Comment 1 jmccann 2008-09-25 19:53:41 EDT
Should be fixed in latest build.

  http://koji.fedoraproject.org/koji/getfile?taskID=844566&name=srpm.log