This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 460640

Summary: dhclient script problem
Product: [Fedora] Fedora Reporter: Zdenek Kabelac <zkabelac>
Component: dhcpAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: marco.crosio, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-29 17:56:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Zdenek Kabelac 2008-08-29 07:35:35 EDT
Description of problem:

Seeing a problem in my boot log - for the file  /sbin/dhclient-script 
Script seems to be part of dhclient package - but as bugzilla doesn't allow me to select this package I'm using dhcp.

Zjišťuji IP informace pro eth0...Nothing to flush.
/sbin/dhclient-script: line 186: [: '': integer expression expected
 hotovo.

(messages in Czech are not important)

Version-Release number of selected component (if applicable):
dhclient-4.0.0-22.fc10.x86_64


How reproducible:


Steps to Reproduce:
1. shown during boot
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Cantrell 2008-08-29 17:56:56 EDT
The problem with this was the initial value of $metric was set to '', instead of being an empty string.  The actual offending line was:

metric="${METRIC:-''}"

The double quotes cause the '' to be interpreted as the value for metric.  I could either remove the double quotes or remove the single quotes, but I couldn't have both.

Fixed in dhcp-4.0.0-23.fc10

Thanks for the report.