Bug 460738

Summary: PDF building requires java-1.6.0-openjdk-devel
Product: [Community] Publican Reporter: Paul W. Frields <stickster>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.6CC: mmcallis, publican-list
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.37 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-09 00:00:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Paul W. Frields 2008-08-30 13:08:26 EDT
publican-0.34-0.fc9

PDF building fails with an indecipherable error without java-1.6.0-openjdk-devel installed.  It's possible this is someone else's problem, but publican may need to require this package.
Comment 1 Jeff Fearn 2008-08-31 20:47:40 EDT
Publican does not require a java devel package to function properly.

This issues seems to occur when you have a different version of the sdk active than the jre you have active.

To clarify, if you hava an SDK installed and the two following commands do not reflect the same java version this error can occur:

alternatives --config java

alternatives --config javac

Cheers, Jeff.
Comment 2 Paul W. Frields 2008-09-08 10:46:42 EDT
Interesting!  Maybe this would be a worthwhile addition to publican-doc?
Comment 3 Jeff Fearn 2008-09-09 00:00:50 EDT
Added FAQ entry to explain why JRE and JDK versions must match and how to check.