Bug 460832

Summary: dragonplayer does not open video file with colon in file name
Product: [Fedora] Fedora Reporter: l ciani <lciani>
Component: kdemultimediaAssignee: Ngo Than <than>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 10CC: kevin, ltinkl, marco.crosio, rdieter, than, tuxbrewr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-31 22:04:46 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description l ciani 2008-09-01 13:59:19 EDT
Description of problem: opening a file with a colon in file name - such as "filename: videofile" - fails with message "couldn't create slave: "Could not create a io-slave: klauncher said: Unkown Ā«filenameĀ» protocol.


Version-Release number of selected component (if applicable): kdemultimedia-4.1.0-1.fc9

Thank you all for your attention.
Comment 1 Kevin Kofler 2008-09-01 15:38:19 EDT
How are you opening the file?
Comment 2 Ngo Than 2008-09-02 05:27:25 EDT
I renamed the test video file to "filename: videofile" and could open it both with dolphin and dragon directly without any problem.
Comment 3 l ciani 2008-09-02 07:00:12 EDT
I have removed ~/.kde/share/config/dragonplayerrc

I have a video file under "~/tmp/filename: videofile.mp4"

I start dragon by typing "dragon" in krunner and selecting the Dragon player icon with the mouse.

An open file dialog pops up on top of the Dragon window asking me which media would I like to play. I click on the "play file" button. The "open file" dialog windows pops up. I select the file called "filename: videofile.mp4" in ~/tmp. The dialog window closes and the focus goes back to the Dragon window.

The Dragon window is blank and the status bar says "no media loaded".

Contents of the dragonplayerrc file right after I close Dragon.
[General]
Recent Urls[$e]=filename: videofile.mp4
TimeFormat=1
Volume=1

[KFileDialog Settings]
Height 800=417
Recent Files[$e]=$HOME/tmp/filename: videofile.mp4,$HOME/tmp/filename: videofile.mp4
Width 1280=1116

[MainWindow]
Height 1024=124
State=AAAA/wAAAAD9AAAAAAAAAi4AAAASAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAAAAACLgAAAAAAAAAA
Width 1280=558

[Phonon::AudioOutput]
Dragon Player_Volume=1

[Recent Dirs]
dragonplayer[$e]=file://$HOME/tmp/,$HOME/Documents/

[filename: videofile.mp4]
Brightness=0
Contrast=0
Hue=0
IsVideo=false
Preferred Size=558,18
Saturation=0
Comment 4 l ciani 2008-09-02 07:02:53 EDT
I open a konsole window, and then key "cd tmp/" and then "dragon filename:\ videofile.mp4", dragon plays the file without any problem.

Content of file right after I closed the dragon window.

[General]
Recent Urls[$e]=file://$HOME/tmp/filename: videofile.mp4
TimeFormat=1
Volume=1

[MainWindow]
Height 1024=533
State=AAAA/wAAAAD9AAAAAAAAAtAAAAGrAAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAEAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAAAAAC0AAAAAAAAAAA
Width 1280=720

[Phonon::AudioOutput]
Dragon Player_Volume=1

[file:///home/peka/tmp/filename: videofile.mp4]
AudioChannel=10600723
Brightness=0
Contrast=0
Hue=0
IsVideo=true
Position=106849
Saturation=0
Subtitle=10600723
Comment 5 Steven M. Parrish 2008-09-25 19:25:43 EDT
Thanks for the report.  I checked upstream and could not find a matching bug.Please file a bug report in the the upstream bugzilla located at http://bugs.kde.org for the particular component involved.

Once you've filed your bug report to the upstream bugzilla, please add the upstream info to this report. We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 6 l ciani 2009-01-31 19:50:28 EST
I have filed this at bugs.kde.org. I believe this is not related to Dragon Player or kdemultimedia, but with kdelibs since the "open file" dialog of all applications I have tried does not open a file with a colon in its file name.

Please see https://bugs.kde.org/show_bug.cgi?id=113595
Comment 7 l ciani 2009-01-31 19:52:15 EST
Also, I am using F10 now. Don't know if this is resolved in F9.
Comment 8 l ciani 2009-01-31 19:54:39 EST
The URL to bugs.kde.org in my comment #6 is wrong.

The correct link is https://bugs.kde.org/show_bug.cgi?id=182648

Apologies.
Comment 9 Rex Dieter 2009-01-31 22:04:46 EST
Thanks, we'll continue to track this issue upstream.