Bug 461898

Summary: yum localinstall/rpm -i allows me to install package obsoleted by another package
Product: Red Hat Enterprise Linux 5 Reporter: Jan Hutař <jhutar>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.3CC: ffesti, lockhart, pmatilai
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-10 12:12:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 466499    

Description Jan Hutař 2008-09-11 05:27:10 EDT
Description of problem:
`yum localinstall`/`rpm -i` allows me to install package obsoleted by installed package.

# rpm -q --obsoletes yum
yum-skip-broken  
yum-basearchonly
# rpm -qp --provides yum-skip-broken-1.1.10-9.el5.noarch.rpm 
config(yum-skip-broken) = 1.1.10-9.el5
yum-skip-broken = 1.1.10-9.el5


Version-Release number of selected component (if applicable):
yum-3.2.19-6.el5.noarch
rpm-4.4.2-48.el5.i386


How reproducible:
always


Steps to Reproduce:
1. # yum localinstall yum-skip-broken-1.1.10-9.el5.noarch.rpm
OR:
1. # rpm -ivh yum-skip-broken-1.1.10-9.el5.noarch.rpm


Actual results:
Package installed without problems


Expected results:
yum/rpm should deny to install obsoleted package


Additional info:
1) Maybe this is expected for yum and bug for rpm (or vice versa), I do not know. If that is expected for both, sorry.
2) Would adding 'Conflicts:' to the yum help with this? This could be problem for custommers because new yum tracebacks with yum-skip-broken installed.
Comment 1 RHEL Product and Program Management 2008-09-12 03:28:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 James Antill 2008-09-15 01:03:48 EDT
 The fact rpm also fails worries me that this is intentional in some way.

 Adding a conflict should work around the problem, so I can do that to yum.
Comment 3 Jan Hutař 2008-09-15 03:44:14 EDT
So the rpm should deny the installation as well, right?
Comment 5 Jan Hutař 2008-09-17 03:24:09 EDT
Hello Panu,
what do you think here (comment #2)?

Thank you,
Jan
Comment 6 Panu Matilainen 2008-09-17 08:50:26 EDT
Dunno about intentional, other than "it's always been that way" (https://lists.dulug.duke.edu/pipermail/rpm-maint/2007-June/000425.html). Apt-rpm does refuse to install obsoleted packages, that caused quite a bit of pain back in the days on Ximian Desktop which installed db1 which was obsoleted by db4 (or something like that)

Permitting installing of obsoleted packages certainly can cause unexpected situations:
1) User installs package A 1.0-1 which obsoletes B
2) User installs package B, no complaints
3) User updates to A 1.0-2, package B gets removed without notice. Unless something actually depends on it, in which case you can't cleanly update a system rpm was previously seemingly happy with.
Comment 8 James Antill 2008-10-07 10:12:22 EDT
In my opinion, if rpm allows the obsoleted packages to be installed yum should too.
 So maybe we should create two RFE's (one each for rpm/yum) to change this behaviuor for RHEL6? For RHEL-5, I think we should just live with it.
Comment 9 James Antill 2008-10-10 12:12:00 EDT
 I've created 466499, for the RHEL6 RFE. I don't think we should change this
mid RHEL5, so I'm closing this.