Bug 462376

Summary: /dev/video0 should be accessible in the XO
Product: [Fedora] Fedora Reporter: Sayamindu Dasgupta <sayamindu>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: bnocera, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-02 11:48:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 461806    

Description Sayamindu Dasgupta 2008-09-15 14:44:48 EDT
Description of problem:
Cheese does not work due to lack of permissions on /dev/video0


How reproducible:
Always

Steps to Reproduce:
1. Start Cheese

  
Actual results:
No picture is seen

Expected results:
A picture from the XO camera should be seen

Additional info:
If you start Cheese from the terminal, you can see that it is failing to access /dev/video0 due to permission issues. Cheese works fine when run as root.
Comment 1 Jeremy Katz 2008-09-15 15:00:02 EDT
A couple of things to check:
* getfacl /dev/video0   (and whatever the symlink points to)
* ck-list-sessions -- make sure ConsoleKit thinks you're on the console
Comment 2 Sayamindu Dasgupta 2008-10-01 13:54:26 EDT
[fedora@localhost ~]$ getfacl /dev/video
getfacl: Removing leading '/' from absolute path names
# file: dev/video
# owner: root
# group: root
user::rw-
group::rw-
other::---

[fedora@localhost ~]$ getfacl /dev/video0
getfacl: Removing leading '/' from absolute path names
# file: dev/video0
# owner: root
# group: root
user::rw-
group::rw-
other::---

=[fedora@localhost ~]$ ck-list-sessions 
Session2:
	unix-user = '500'
	realname = 'Fedora Live'
	seat = 'Seat1'
	session-type = ''
	active = TRUE
	x11-display = ':0'
	x11-display-device = '/dev/tty7'
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2008-10-01T21:42:55.704044Z'
	login-session-id = ''
[fedora@localhost ~]$
Comment 3 Jeremy Katz 2008-10-02 11:48:25 EDT
Checking with the newer build I posted last night, this seems to work okay now