Bug 462484

Summary: net-snmp and net-snmp-utils contain perl scripts that should be moved to net-snmp-perl
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: net-snmpAssignee: Jan Safranek <jsafrane>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideKeywords: Reopened
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: net-snmp-5.4.2-3.fc10 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-26 14:02:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 462851    

Description Peter Robinson 2008-09-16 16:47:35 UTC
There is already an net-snmp-perl package so the perl scripts that are currently in the net-snmp and net-snmp-utils should be moved to this sub package so that the aforementioned packages don't depend on perl as well.

The perl files are:

net-snmp package:
- Standard package
/usr/share/snmp/snmp_perl.pl
/usr/share/snmp/snmp_perl_trapd.pl
/usr/share/doc/net-snmp-5.4.1/ipf-mod.pl

net-snmp-utils package:
/usr/bin/snmpconf
/usr/bin/fixproc
/usr/share/snmp/snmp_perl.pl
/usr/share/snmp/snmp_perl_trapd.pl
/usr/bin/traptoemail

Comment 1 Jan Safranek 2008-09-23 10:20:26 UTC
The purpose of net-snmp-perl package is to contain NetSNMP:: perl modules + the utilities that use it. It should not contain all perl scripts, which come with net-snmp package.

I admit that distribution of some scripts among the subpackages is bad (e.g. /usr/share/snmp/snmp_perl.pl should really go to net-snmp-perl, because it references NetSNMP::agent), but some script should be in net-snmp.rpm, because they are here to help with configuration of the snmp server (like /usr/bin/snmpconf, now wrongly distributed in net-snmp-utils) and do not have other dependencies than perl itself.

All I can do is to try fix net-snmp-utils so it won't depend on perl - the perl scripts here are useful more or less only on the server side. I can't drop net-snmp.rpm dependency on perl, even the snmpd daemon itself needs to dynamically link to libperl*.so.

Comment 2 Peter Robinson 2008-09-23 11:27:21 UTC
That would be fine if the net-snmp-utils doesn't depend on the net-snmp package so you can have the utils installed which are useful on their own without having to have the full net-snmp server installed.

Comment 3 Jan Safranek 2008-09-26 10:50:46 UTC
Fixed in net-snmp-5.4.2-2.fc10, do you *really* want to fix it in F9? Such changes should IMHO not happen in stable release.

Comment 4 Peter Robinson 2008-09-26 11:03:26 UTC
I didn't mention F-9 that I'm aware of. I'm quite happy for it to be in F-10 as that's what I'm targetting it for.

Comment 5 Peter Robinson 2008-09-26 13:12:08 UTC
reopening as net-snmp-utils requires net-snmp which in turn requires perl.

Comment 6 Jan Safranek 2008-09-26 13:47:32 UTC
oops, good catch. Utils now depends on net-snmp-libs only (to get the MIBs).