Bug 462578

Summary: "No option 'instimage' in section: 'stage2'"
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-17 12:37:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jóhann B. Guðmundsson 2008-09-17 05:44:25 EDT
Description of problem:
Running from an f9.i386 against rawhide results in preupgrade 
being stalled while installer metadata..

[root@johannbg-1002 ~]# rpm -qa | grep preupgrade
preupgrade-0.9.3-3.fc9.noarch
[root@johannbg-1002 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                       71G  9.4G   58G  15% /
/dev/sda1             190M   23M  158M  13% /boot
tmpfs                 505M   48K  505M   1% /dev/shm
[root@johannbg-1002 ~]# preupgrade
Loaded plugins: dellsysidplugin, refresh-packagekit
No package matched to remove
python-gammu-0.26-1.fc10.i386 from anaconda-upgrade has depsolving problems
  --> Missing Dependency: libGammu.so.3 is needed by package python-gammu-0.26-1.fc10.i386 (anaconda-upgrade)
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
    self.pu.retrieve_treeinfo()
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib/python2.5/ConfigParser.py", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'

 
Version-Release number of selected component (if applicable):


How reproducible:

Run preupgrade on an F9 system

Steps to Reproduce:
1. 
2.
3.
  
Actual results:

Upgrade stalls..

Expected results:

Upgrade proceed as normal

Additional info:
Comment 1 Will Woods 2008-09-17 12:37:47 EDT

*** This bug has been marked as a duplicate of bug 459935 ***