Bug 462899

Summary: When disconnecting, inputting on xterm -> imsettings-applets Segmentation fault
Product: [Fedora] Fedora Reporter: sangu <sangu.fedora>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 10CC: i18n-bugs, petersen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-07-22 10:31:05 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
log file using http://code.google.com/p/libgxim/wiki/HowToDebug
none
disconnect-> input on xterm. debug log http://code.google.com/p/libgxim/wiki/HowToDebug none

Description sangu 2008-09-19 11:22:42 EDT
Description of problem:

(imsettings-applet:28151): libimsettings-xim-CRITICAL **: compose_lookup: assertion `sequence != NULL' failed

Program received signal SIGSEGV, Segmentation fault.
0x009ec56b in xim_loopback_real_xim_forward_event (proto=0x81ebce0, imid=2, 
    icid=<value optimized out>, flag=0, event=0x8077af0, data=0x80ce800)
    at loopback.c:879
879			ic->sequence_state = NULL;

(gdb) bt
#0  0x009ec56b in xim_loopback_real_xim_forward_event (proto=0x81ebce0, 
    imid=2, icid=<value optimized out>, flag=0, event=0x8077af0, 
    data=0x80ce800) at loopback.c:879
#1  0x00cad199 in gxim_marshal_BOOLEAN__UINT_UINT_UINT_BOXED (
    closure=0x8329b88, return_value=0xbfffe9e8, n_param_values=5, 
    param_values=0x81ad348, invocation_hint=0x0, marshal_data=0x9ec470)
    at gximmarshal.c:627
#2  0x008b21db in IA__g_closure_invoke (closure=0x8329b88, 
    return_value=0xbfffe9e8, n_param_values=5, param_values=0x81ad348, 
    invocation_hint=0x0) at gclosure.c:767
#3  0x00c96512 in g_xim_protocol_closure_emit_signal (closure=0x80f7d98, 
    proto=0x81ebce0) at gximprotocol.c:2993
#4  0x00ca469e in g_xim_protocol10_closure_XIM_FORWARD_EVENT (
    closure=0x80f7d98, proto=0x81ebce0, stream=0x81af070, error=0xbfffec58, 
    user_data=0x0) at gximprotocol10.c:934
#5  0x00c967ea in g_xim_protocol_closure_marshal_BOOLEAN__OBJECT_OBJECT_POINTER
    (closure=0x80f7d98, return_value=0xbfffeba8, n_param_values=3, 
    param_values=0x82a4f90, invocation_hint=0x0, marshal_data=0x0)
    at gximprotocol.c:219
#6  0x008b21db in IA__g_closure_invoke (closure=0x80f7d98, 
    return_value=0xbfffeba8, n_param_values=3, param_values=0x82a4f90, 
    invocation_hint=0x0) at gclosure.c:767
#7  0x00c9e469 in g_xim_protocol_translate (proto=0x81ebce0, data=0x8079568, 
---Type <return> to continue, or q <return> to quit---
    length=44, error=0xbfffec58) at gximprotocol.c:576
#8  0x00c9e986 in g_xim_protocol_process_event (proto=0x81ebce0, 
    event=0x8077b40, error=0xbfffec58) at gximprotocol.c:431
#9  0x00ca9f6e in g_xim_srv_tmpl_real_client_event (core=0x80ce800, 
    event=0x8077b40) at gximsrvtmpl.c:671
#10 0x00cadba6 in gxim_marshal_BOOLEAN__BOXED (closure=0x80c46d0, 
    return_value=0xbfffee30, n_param_values=2, param_values=0x80d65b8, 
    invocation_hint=0xbfffee1c, marshal_data=0xca9ef0) at gximmarshal.c:161
#11 0x008b0959 in g_type_class_meta_marshal (closure=0x80c46d0, 
    return_value=0xbfffee30, n_param_values=2, param_values=0x80d65b8, 
    invocation_hint=0xbfffee1c, marshal_data=0x60) at gclosure.c:878
#12 0x008b21db in IA__g_closure_invoke (closure=0x80c46d0, 
    return_value=0xbfffee30, n_param_values=2, param_values=0x80d65b8, 
    invocation_hint=0xbfffee1c) at gclosure.c:767
#13 0x008c82cd in signal_emit_unlocked_R (node=0x80c4788, detail=0, 
    instance=0x80ce800, emission_return=0xbfffef68, 
    instance_and_params=0x80d65b8) at gsignal.c:3282
#14 0x008c9bbb in IA__g_signal_emit_valist (instance=0x80ce800, signal_id=165, 
    detail=0, var_args=0xbfffefc0 "�����\211\a\b����\002E\213")
    at gsignal.c:2987
#15 0x008ca1b6 in IA__g_signal_emit (instance=0x80ce800, signal_id=165, 
    detail=0) at gsignal.c:3034
#16 0x00c8ac95 in g_xim_core_dispatch_events (gdk_xevent=0xbffff258, 
---Type <return> to continue, or q <return> to quit---
    event=0x8077b90, data=0x80ce800) at gximcore.c:141
#17 0x00565061 in gdk_event_apply_filters () at gdkevents-x11.c:349
#18 gdk_event_translate (display=0x8073008, event=0x8077b90, 
    xevent=0xbffff258, return_exposes=0) at gdkevents-x11.c:988
#19 0x005669d3 in _gdk_events_queue (display=0x8073008) at gdkevents-x11.c:2299
#20 0x00566dff in gdk_event_dispatch (source=0x807b110, callback=0, 
    user_data=0x0) at gdkevents-x11.c:2359
#21 0x00925218 in g_main_dispatch () at gmain.c:2142
#22 IA__g_main_context_dispatch (context=0x807b158) at gmain.c:2695
#23 0x009288c3 in g_main_context_iterate (context=0x807b158, block=1, 
    dispatch=1, self=0x80625d8) at gmain.c:2776
#24 0x00928de2 in IA__g_main_loop_run (loop=0x80ce730) at gmain.c:2984
#25 0x002591d9 in IA__gtk_main () at gtkmain.c:1200
#26 0x0804ea7e in main (argc=Cannot access memory at address 0x2f3
) at main.c:1298


Version-Release number of selected component (if applicable):
0.104.0-1.fc10

How reproducible:
always

Steps to Reproduce:
1.  connect on imsettings-applet
2.  launch xterm
3. disconect on imsettings-applet
4. input xterm  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2008-09-19 11:28:45 EDT
Created attachment 317203 [details]
log file using http://code.google.com/p/libgxim/wiki/HowToDebug
Comment 2 Akira TAGOH 2008-09-20 21:09:04 EDT
Thanks for reporting. this will be fixed in the next release.
Comment 3 Akira TAGOH 2008-09-25 03:35:44 EDT
Fixed in imsettings-0.104.1-1.fc10.
Comment 4 sangu 2008-09-26 11:08:27 EDT
Created attachment 317801 [details]
disconnect-> input on xterm. debug log http://code.google.com/p/libgxim/wiki/HowToDebug

In imsettings-0.104.1-1.fc10
When Disconnecting, inputing on xterm -> xterm freezes, imsettings-applet  icon doesn't changed.

$ imsettings-applet 
Acceleration key: disabled
W:Error while processing a value type NestedList: Error while processing a value type XFontSet: Unable to compose a value type XFontSet properly due to the size difference: expected size: 446, actual size: 448
W:No links for imid 1
W:Unknown IC attribute cursor: no attribute id in the client side is assigned.
W:Invalid input-context ID: 1

(imsettings-applet:31498): GXIM-CRITICAL **: g_xim_attr_get_gtype_by_name: assertion `attribute_name != NULL' failed
W:Error while processing a value type LISTofXICATTRIBUTE: Attribute ID 218 isn't available in GXimICAttr

(imsettings-applet:31498): GXIM-CRITICAL **: g_xim_attr_get_gtype_by_name: assertion `attribute_name != NULL' failed
W:Error while processing a value type LISTofXICATTRIBUTE: Attribute ID 24 isn't available in GXimICAttr

(imsettings-applet:31498): GXIM-CRITICAL **: g_xim_attr_get_gtype_by_name: assertion `attribute_name != NULL' failed
W:Error while processing a value type LISTofXICATTRIBUTE: Attribute ID 228 isn't available in GXimICAttr
Comment 5 Bug Zapper 2008-11-25 22:08:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Akira TAGOH 2009-07-22 10:31:05 EDT
No segfault issues anymore. an issue at Comment #4 is caused by xterm doesn't support reconnecting. unfortunately in such applications, no way of avoiding a freeze. anyway, that would be better filing another bug. closing.