This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 465610

Summary: pulseaudio stop responding
Product: [Fedora] Fedora Reporter: Alexey Kuznetsov <axet>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: gilboad, lkundrak, lpoetter, pierre-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-19 16:54:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Alexey Kuznetsov 2008-10-04 10:40:11 EDT
After fully reboot i start listening my radio station by last.fm client. in 5-10 minutes list.fm client crashed and i unable to restart. Only one solution to start listen any sounds is type a command:

# pulseaudo&

after that everyting work fine for hours.


i tried to gdb process iidiatly after reboot and got those results:

0x00110416 in __kernel_vsyscall ()
Missing separate debuginfos, use: debuginfo-install PolicyKit.i386 alsa-lib.i386 dbus.i386 e2fsprogs.i386 expat.i386 glibc.i686 hal.i386 libICE.i386 libSM.i386 libX11.i386 libXau.i386 libXdmcp.i386 libcap.i386 liboil.i386 libsamplerate.i386 libselinux.i386 libsndfile.i386 libtool.i386 libxcb.i386 tcp_wrappers.i386
(gdb) c
Continuing.

Program received signal SIGXCPU, CPU time limit exceeded.
[Switching to Thread 0xb7ca4b90 (LWP 2917)]
0x00144011 in pa_memchunk_reset (c=<value optimized out>) at pulsecore/memchunk.c:69
69	pa_memchunk* pa_memchunk_reset(pa_memchunk *c) {
(gdb) c
Continuing.

Program received signal SIGXCPU, CPU time limit exceeded.
pa_mempool_block_size_max (p=<value optimized out>) at pulsecore/memblock.c:726
726	size_t pa_mempool_block_size_max(pa_mempool *p) {
(gdb) bt
#0  pa_mempool_block_size_max (p=<value optimized out>) at pulsecore/memblock.c:726
#1  0x00161375 in pa_sink_input_peek (i=<value optimized out>, length=<value optimized out>, chunk=<value optimized out>, volume=<value optimized out>)
    at pulsecore/sink-input.c:444
#2  0x00159cca in fill_mix_info (s=<value optimized out>, length=<value optimized out>, info=<value optimized out>, maxinfo=<value optimized out>)
    at pulsecore/sink.c:344
#3  0x0015a0f9 in pa_sink_render_into (s=<value optimized out>, target=<value optimized out>) at pulsecore/sink.c:509
#4  0x0015a61c in pa_sink_render_into_full (s=<value optimized out>, target=<value optimized out>) at pulsecore/sink.c:583
#5  0x0022b9bc in thread_func (userdata=0x91232e0) at modules/module-alsa-sink.c:185
#6  0x00177527 in internal_thread_func (userdata=<value optimized out>) at pulsecore/thread-posix.c:73
#7  0x00c8232f in start_thread () from /lib/libpthread.so.0
#8  0x00bbd20e in clone () from /lib/libc.so.6
(gdb) c
Continuing.

Program received signal SIGXCPU, CPU time limit exceeded.
[Switching to Thread 0xb80ab720 (LWP 2915)]
0x00110416 in __kernel_vsyscall ()
(gdb) bt
#0  0x00110416 in __kernel_vsyscall ()
#1  0x00c89058 in recvmsg () from /lib/libpthread.so.0
#2  0x002fe4d7 in pa_iochannel_read_with_creds (io=0x9133c40, data=0x91398e4, l=20, creds=0x9139958, creds_valid=0xbfdc2f3b) at pulsecore/iochannel.c:349
#3  0x0032de24 in do_something (p=0x9139890) at pulsecore/pstream.c:667
#4  0x0032f019 in io_callback (io=0x9133c40, userdata=0xbfdc2e30) at pulsecore/pstream.c:215
#5  0x002fd318 in callback (m=0x9117724, e=0x9121408, fd=30, f=<value optimized out>, userdata=0x9133c40) at pulsecore/iochannel.c:121
#6  0x00120d89 in pa_mainloop_dispatch (m=<value optimized out>) at pulse/mainloop.c:679
#7  0x001210e1 in pa_mainloop_iterate (m=<value optimized out>, block=<value optimized out>, retval=<value optimized out>) at pulse/mainloop.c:922
#8  0x001211a4 in pa_mainloop_run (m=<value optimized out>, retval=<value optimized out>) at pulse/mainloop.c:937
#9  0x08050c75 in main (argc=2, argv=0xbfdc31c4) at daemon/main.c:810
(gdb) c
Continuing.

Program received signal SIGXCPU, CPU time limit exceeded.
[Switching to Thread 0xb7ca4b90 (LWP 2917)]
0x0011e447 in __i686.get_pc_thunk.bx () from /usr/lib/libpulsecore.so.5
(gdb) bt
#0  0x0011e447 in __i686.get_pc_thunk.bx () from /usr/lib/libpulsecore.so.5
#1  0x0015a4c1 in pa_sink_render_into_full (s=<value optimized out>, target=<value optimized out>) at pulsecore/sink.c:563
#2  0x0022b9bc in thread_func (userdata=0x91232e0) at modules/module-alsa-sink.c:185
#3  0x00177527 in internal_thread_func (userdata=<value optimized out>) at pulsecore/thread-posix.c:73
#4  0x00c8232f in start_thread () from /lib/libpthread.so.0
#5  0x00bbd20e in clone () from /lib/libc.so.6
(gdb) c
Continuing.
Comment 1 Alexey Kuznetsov 2008-10-07 18:20:38 EDT
nope, pulseaudio also crash when i restart it from console.

[axet@axet-laptop ~]$ pulseaudio 
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
Soft CPU time limit exhausted, terminating.
[axet@axet-laptop ~]$
Comment 2 Alexey Kuznetsov 2008-10-15 08:49:08 EDT
same for fedora 10 beta (+rawhide update)
Comment 3 Gilboa Davara 2008-10-16 11:56:54 EDT
Seeing the same.
Fedora 9, x86_64.

$ rpm -q pulseaudio
pulseaudio-0.9.10-2.fc9.x86_64
$ uname -a
Linux gilboa-work-dev 2.6.26.5-45.fc9.x86_64 #1 SMP Sat Sep 20 03:23:12 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

- Gilboa
Comment 4 Gilboa Davara 2008-10-16 11:58:44 EDT
P.S. I'm seeing RT errors. RT patch-set applied?
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted

- Gilboa
Comment 5 Gilboa Davara 2008-10-16 13:33:25 EDT
If indeed we are talking about pulse+RT patches, anyone tested them without adding the current user to the pulse-rt group?

- Gilboa
Comment 6 Gilboa Davara 2008-10-16 13:49:10 EDT
No go. Pulse looks broken.

$ groups | egrep -o pulse-rt
pulse-rt
$ pulseaudio
W: pid.c: Stale PID file, overwriting.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.
Aborted
$
Comment 7 Lennart Poettering 2008-10-19 16:53:44 EDT
Looks like yet another iteration of 462200
Comment 8 Lennart Poettering 2008-10-19 16:54:00 EDT

*** This bug has been marked as a duplicate of bug 462200 ***