Bug 465658

Summary: pulseaudio crackles
Product: [Fedora] Fedora Reporter: Vedran Miletić <vedran>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: bbbush.yuan, lkundrak, lpoetter, notting, pierre-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-24 16:25:32 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 457945    

Description Vedran Miletić 2008-10-05 05:59:41 EDT
Description of problem:
When playing two mp3 songs at once, PulseAudio starts to generate a lot of crackling.

Version-Release number of selected component (if applicable):
[vedran@kalopsia ~]$ pulseaudio --version
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root priviliges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
pulseaudio 0.9.12

How reproducible:
Every time.

Steps to Reproduce:
1. mplayer first-song.mp3
2. mplayer second-song.mp3
Actual results:
Both songs played + lots of crackling.

Expected results:
Both songs played.

Additional info:
If I play both songs using hardware mixing on my E-mu 1212m card, it works normally.
If I play both songs on same card using pulseaudio mixing, it crackles.
User is in pulse-rt group.
Comment 1 Vedran Miletić 2008-10-05 12:50:08 EDT
There is additional information in this mailing list thread: https://tango.0pointer.de/pipermail/pulseaudio-discuss/2008-September/002374.html

However, it isn't specific to HDA. Happens with other cards too.
Comment 2 Yijun Yuan 2008-10-13 20:17:30 EDT
play something with "padsp realplay", pause it, then continue, you will hear some a fierce noise. Is this a same problem or not?
Comment 3 Bill Nottingham 2008-10-24 16:25:32 EDT

*** This bug has been marked as a duplicate of bug 466840 ***