Bug 466478

Summary: Videos start to crawl after some time
Product: [Fedora] Fedora Reporter: Bartosz Malasiewicz <bartucha82>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: rawhideCC: antonio.montagnani, lkundrak, lpoetter, martin.sourada, mishu, pierre-bugzilla, sindrepb, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-24 16:30:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Xorg.0.log none

Description Bartosz Malasiewicz 2008-10-10 09:23:11 EDT
When watching a video for over 30 minutes the video starts to crawl and freezes. 
ps -A is not showing any processes that would hog the CPU. Neither there is any information about possible errors in /var/log/messages and Xorg.0.log. The system was updated to the latest rawhide version available on Thursday 09/10/2008. The same issue persists when I log out and log in into my desktop environment (Gnome). The system is currently using EXA. The same issue happens when I watch too many videos on webpages for a long time. The simply freeze. The sound is running fine and the whole system is responding.
Comment 1 Matěj Cepl 2008-10-10 12:38:12 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Bartosz Malasiewicz 2008-10-11 02:38:52 EDT
Created attachment 320086 [details]
Xorg.0.log

Here is my Xorg.0.log. I don't use any xorg.conf file. Everything is automatically detected.
Comment 3 Bartosz Malasiewicz 2008-10-18 16:31:58 EDT
I'm affraid hat this issue is not intel driver related. I have found some suspicious messages regarding pulseaudio. I have removed the pulseaudio daemon and other related libraries and right now I'm running pure alsa. The problems with videos subsided. Can you assign this bug to the pulseaudio component?
Comment 4 Martin Sourada 2008-10-23 11:58:04 EDT
I'm seeing this too. It seem to started happening with some of the post-f10-beta updates, or at least I haven't noticed it in beta. It's definitely a pulse audio problem for me - doing pulseaudio -k and restarting the applications gives me another nice 30 or so minutes before this happens again. 

Similar problems arises with audio only application where rhythmbox simply stops playing. Retrying to play the song leads to rhythmbox starting it to play but not showing progress and dying shortly after.

The timings are pretty much same both for video and sound and it's always about 30-35 mins of active playing.

It definitely worked on F9 on the same hardware. Is there any useful info I could provide?
Comment 5 antonio montagnani 2008-10-23 12:28:37 EDT
I suggest to have a look to bug 462200
Comment 6 Lennart Poettering 2008-10-24 16:18:04 EDT
Please retry with 0.9.13-4!
Comment 7 Lennart Poettering 2008-10-24 16:30:18 EDT

*** This bug has been marked as a duplicate of bug 462200 ***
Comment 8 Martin Sourada 2008-10-24 16:32:11 EDT
(In reply to comment #6)
> Please retry with 0.9.13-4!

I noticed matthias' mail on the test-list and was going to report the results
after further testing, but so far it looks like this version fixes the issue
for me (but I have only a little more than an hour and half or so of testing).