Bug 466665

Summary: Invalid combination of attributes on element <allow>
Product: Red Hat Enterprise Linux 5 Reporter: Nate Straz <nstraz>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED DUPLICATE QA Contact: desktop-bugs <desktop-bugs>
Severity: urgent Docs Contact:
Priority: high    
Version: 5.3CC: davidz, dcbw, syeghiay, tpelka
Target Milestone: betaKeywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-14 08:23:27 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nate Straz 2008-10-12 09:28:55 EDT
Description of problem:

dbus-daemon cannot start because of problems in /etc/dbus-1/session.conf.
The only error message I get is:

Failed to start message bus: Invalid combination of attributes on element <allow>

This prevents me from logging into X

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Upgrade to dbus version listed
2. dbus-daemon --session

Actual results:

Expected results:

Additional info:
Comment 1 Nate Straz 2008-10-12 09:42:39 EDT
The last version of dbus I had installed was 1.0.0-7.el5.

diff -urN 1.0.0-7/etc/dbus-1/session.conf 1.1.2-11/etc/dbus-1/session.conf
--- 1.0.0-7/etc/dbus-1/session.conf     2008-10-12 09:36:52.365751000 -0400
+++ 1.1.2-11/etc/dbus-1/session.conf    2008-10-12 09:37:17.187452000 -0400
@@ -14,17 +14,44 @@
   <policy context="default">
     <!-- Allow everything to be sent -->
-    <allow send_destination="*"/>
+    <allow send_destination="*" eavesdrop="true"/>
     <!-- Allow everything to be received -->
     <allow eavesdrop="true"/>
     <!-- Allow anyone to own anything -->
     <allow own="*"/>

After removing the eavesdrop="true" attribute I can again log into X.
Comment 3 David Zeuthen 2008-10-13 20:37:25 EDT
Not sure why the config file wasn't updated; the upstream patch


changed it. Maybe we're using that horribly broken %config(noreplace) directive. If so, we need to fix that ASAP. Dan, you did the rebase, any ideas?
Comment 4 Nate Straz 2008-10-13 21:18:59 EDT
Capturing conversation I had with David on IRC.  The long and short of it, this appears to be an upgrade issue where I ended up with a new i386 version of dbus in the package rpmdb, but an old x86_64 dbus package on disk.

davidz>	hello
refried>	I just saw your comment
refried>	the config file was updated
refried>	dbus-daemon failed to parse it because of that change
davidz>	but it works on the next login?
refried>	I'm not sure what you mean
refried>	I couldn't log into X to fix it
davidz>	that's odd
refried>	I did the edit from the console
davidz>	I need to talk to dcbw; maybe we somehow botched the rebase
davidz>	but I'm pretty sure it worked for him
davidz>	it seems odd it would only update the config file, not the /bin/dbus-daemon binary
davidz>	is rpm -V dbus saying the right thing?
refried>	[nstraz@tin ~]$ rpm -q dbus
refried>	dbus-1.1.2-11.el5
refried>	[nstraz@tin ~]$ dbus-daemon --version
refried>	D-Bus Message Bus Daemon 1.0.0
refried>	[nstraz@tin ~]$ rpm -V dbus
refried>	S.5....T  c /etc/dbus-1/session.conf
refried>	S.?.....    /lib/dbus-1/dbus-daemon-launch-helper
refried>	hrm, I didn't think to look to see if dbus-daemon didn't return the right version
davidz>	there's something very wrong going on
davidz>	can you check the md5 of /bin/dbus-daemon against that in the rpm?
refried>	[root@tin log]# md5sum /bin/dbus-daemon
refried>	38fa3678753e95f99d43a783c90d7f36  /bin/dbus-daemon
refried>	I don't remember how to get sums out of rpmquery
davidz>	maybe they're in brew.. let me check
refried>	rpm -V doesn't complain so I'll bet it's the same
davidz>	can you add this to the bug report?
davidz>	the different version numbers are... scary.. to say the least
refried>	ok
refried>	I figured I'd try to contact you since bugzilla is so slow today
davidz>	what arch are you on?
davidz>	https://brewweb.devel.redhat.com/buildinfo?buildID=76049
refried>	x86_64
davidz>	https://brewweb.devel.redhat.com/fileinfo?rpmID=1188561&filename=/bin/dbus-daemon
davidz>	MD5 Sum	3443021e21d45f8f01224d99548d2e52
davidz>	so..
davidz>	something is horribly wrong
davidz>	horribly, horribly wrogon
davidz>	wrong even
refried>	that doesn't make any sense
davidz>	if I were to guess.. this looks like a nasty bug with rpm
davidz>	but that's only a guess
refried>	[root@tin log]# rpm -q --qf "%{N}-%{V}-%{R}.%{ARCH}\n" dbus
refried>	dbus-1.1.2-11.el5.i386
davidz>	oh
davidz>	wow
davidz>	I thought you were on x86_64?
refried>	I am
davidz>	what does file /bin/dbus-daemon say?
davidz>	also, what does rpm -q dbus.x86_64 say?
refried>	[root@tin log]# file /bin/dbus-daemon
refried>	/bin/dbus-daemon: ELF 64-bit LSB executable, AMD x86-64, version 1 (SYSV), for GNU/Linux 2.6.9, dynamically linked (uses shared libs), for GNU/Linux 2.6.9, stripped
refried>	[root@tin log]# rpm -q dbus.x86_64
refried>	package dbus.x86_64 is not installed
refried>	Apr 24 08:29:45 Updated: dbus - 1.0.0-7.el5.x86_64
refried>	Apr 24 08:30:38 Updated: dbus-x11 - 1.0.0-7.el5.x86_64
refried>	Apr 24 08:30:41 Updated: dbus - 1.0.0-7.el5.i386
refried>	Apr 24 08:30:59 Updated: dbus-devel - 1.0.0-7.el5.x86_64
refried>	Oct 07 12:18:00 Installed: dbus-libs - 1.1.2-11.el5.i386
refried>	Oct 07 12:18:19 Updated: dbus-glib - 0.73-8.el5.i386
refried>	Oct 07 12:22:56 Installed: dbus-libs - 1.1.2-11.el5.x86_64
refried>	Oct 07 12:22:57 Updated: dbus - 1.1.2-11.el5.i386
refried>	Oct 07 12:22:58 Updated: dbus-glib - 0.73-8.el5.x86_64
refried>	Oct 07 12:23:55 Updated: dbus-x11 - 1.1.2-11.el5.x86_64
refried>	Oct 07 12:23:57 Updated: dbus-devel - 1.1.2-11.el5.x86_64
refried>	Oct 07 12:23:58 Updated: dbus-glib-devel - 0.73-8.el5.x86_64
refried>	that's grep dbus /var/log/yum.log
davidz>	what's the output of "rpm -qa |grep dbus"?
refried>	[root@tin log]# rpm -qa --qf "%{N}-%{V}-%{R}.%{ARCH}\n"  | grep dbus
refried>	dbus-1.1.2-11.el5.i386
refried>	dbus-libs-1.1.2-11.el5.i386
refried>	dbus-glib-0.73-8.el5.i386
refried>	dbus-devel-1.1.2-11.el5.x86_64
refried>	dbus-python-0.70-7.el5.x86_64
refried>	dbus-x11-1.1.2-11.el5.x86_64
refried>	dbus-glib-0.73-8.el5.x86_64
refried>	dbus-glib-devel-0.73-8.el5.x86_64
refried>	dbus-libs-1.1.2-11.el5.x86_64
davidz>	anyway
davidz>	something is horribly busted with yum/rpm/multilib here
refried>	very very strange
davidz>	ok, let me suggest to paste this entire conversation into the bug
davidz>	and probably avoid touching the system
refried>	okay, no more workstation upgrades for me
davidz>	since it may be needed to track this down
davidz>	I'm not sure how you ended up with an i386 dbus... you should be having an x86_64 one
davidz>	and the fact that the MD5 sums doesn't match... and you have the wrong binary (according to --version) output
davidz>	would probably be good to reassign this to the yum or rpm component
davidz>	am pretty sure it's a bug there...
Comment 5 Ben Levenson 2008-10-13 22:02:19 EDT
most likely a dup of 466007
Comment 7 James Antill 2008-10-14 08:23:27 EDT

*** This bug has been marked as a duplicate of bug 466007 ***