Bug 466840

Summary: Snaps, crackles, pops and dropouts from pulseaudio on F10 beta
Product: [Fedora] Fedora Reporter: Thomas Cameron <tcameron>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dcantrell, jbastian, john5342, kernel-maint, lkundrak, lpoetter, martin, notting, pierre-bugzilla, vedran
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-24 16:31:07 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 438944, 465130    

Description Thomas Cameron 2008-10-13 22:39:15 EDT
Description of problem:

I have an Abit KN8 SLI motherboard with an AMD Athlon 64 X2 Dual Core Processor 4600+ (Socket 939) and 4GB memory.  The sound card is an on-board nVidia Corporation CK804 AC'97 Audio Controller (rev a2).

I installed off the F10 x86_64 beta DVD ISO image and updated against rawhide on 13 October 2008 at about 7:00 p.m.

I'm noticing a *lot* of audio pops and snaps.  For instance, I use Pidgin and I have sound events turned on for pretty much everything.  Often the snaps come as a sound event occurs like someone "speaking" on IRC - instead of a clear note when someone "talks" there is a snap and then the note.  Also, when someone joins or leaves, the note is often (but not always) interrupted by either a short sound dropout or a pop.

In other cases, just sitting here typing away on this bugzilla with no sound event being triggered, I hear random pops.  Some are as close as 3-4 seconds, but then it will go quiet for 45-60 seconds.

This system works great with RHEL 5.2 x86_64 installed, and I don't recall any audio issues under F9.  This seems to be unique to F10/rawhide.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-2.fc10.x86_64

How reproducible:
Install F10 beta, update off of rawhide.
 
Actual results:
Audio with pops, snaps and dropouts, either with or without other audio events.

Expected results:
Smooth audio.

Additional info:
Sysreport is available at http://www.camerontech.com/sysreport-case.camerontech.net.2008101421449.tar.bz2 if you'd like it.
Comment 1 Jeff Bastian 2008-10-14 10:16:50 EDT
I'm also experiencing lots of snaps, crackles, and pops, but coming from a different route.  I installed Fedora 9 under VMware Fusion, where the audio was working fine, and then upgraded to Fedora 10 Alpha (and then Beta) following these instructions
  http://fedoraproject.org/wiki/YumUpgradeFaq

Under Gnome, if I go to
  System -> Preferences -> Hardware -> Sound
and play the test sound, this is what I get when I try the various devices available for sound playback:

1. Autodetect:                                      silence
2. Ensoniq AudioPCI ENS1371 ES1371 DAC1 (ALSA):     works
3. Ensoniq AudioPCI ENS1371 ES1371 DAC2/ADC (ALSA): error*
4. Ensoniq AudioPCI ENS1371 ES1371 DAC2/ADC (OSS):  works**
5. Ensoniq AudioPCI ENS1371 ES1371 DAC2/ADC (OSS):  works***
6. Ensoniq AudioPCI ENS1371 ES1371 DAC2/ADC (OSS):  works***
7. ALSA - Advanced Linux Sound Architecture:        snaps/crackles/pops
8. PulseAudio Sound Server:                         silence

* audiotestsrc wave=sine freq=512 !
  audioconvert ! audioresample !
  gconfaudiosink: Could not open audio device for playback

** a sine wave is heard, but then a light-sabre-sound is heard
   when I stop playing the test sound

*** 4, 5, and 6 all have the same description


It looks like the ALSA interface is what's generating the snaps, crackles, and pops.
Comment 2 Jesse Keating 2008-10-14 13:18:48 EDT
I get the pops and crackles, again mostly from pidgin, and I've got intel sound hda as part of a Dell M1330.  00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
Comment 3 john5342 2008-10-14 19:45:55 EDT
I am getting the exact same problem in F9 using the same CK804 AC'97 chipset. I get snapping and popping at the beginning and end of most system sounds from virtually all programs and a lot of sounds get cut off. One notable thing is that this also happens during hardware init on boot. That sort of rules out pulseaudio i think. Also this has happened for me since the beginning of F9 but never occured on F8.

Also on a side note i _think_ the intel chipset in comment 2 also uses AC97 codec. Might be just chance.
Comment 4 MartinG 2008-10-15 17:08:27 EDT
I have the same problem, Fedora Rawhide on a Dell Latitude X1 (intel audio, see below)

For example, when I start pulseaudio from the command line, I can hear a "pop" in the speaker, even though I have muted both "Front" and "PCM" in the
mixer settings.

Output of 'lspci -v':
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
        Subsystem: Dell Device 01a3
        Flags: bus master, medium devsel, latency 0, IRQ 16
        I/O ports at ed00 [size=256]
        I/O ports at ec40 [size=64]
        Memory at dfebfe00 (32-bit, non-prefetchable) [size=512]
        Memory at dfebfd00 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
        Kernel driver in use: Intel ICH
        Kernel modules: snd-intel8x0

00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03) (prog-if 00 [Generic])
        Subsystem: Conexant Device 5423
        Flags: bus master, medium devsel, latency 0, IRQ 17
        I/O ports at ee00 [size=256]
        I/O ports at ec80 [size=128]
        Capabilities: [50] Power Management version 2
        Kernel driver in use: Intel ICH Modem
        Kernel modules: snd-intel8x0m


I am running Fedora Rawhide KDE 4:
kernel-2.6.27-0.398.rc9.fc10.i686
pulseaudio-0.9.13-2.fc10.i386
kdelibs-4.1.2-4.fc10.i386

In systemsettings/Sound I have four devices listed under Default
Output device preferences:
PulseAudio Sound Server
PulseAudio
Default
Intel ICH6 with STAC9752,53 (Intel ICH6)


This will give a click/pop/boink in the internal speaker when pulseaudio is started:
------------------------------------------------------------
$ killall artsd
$ pulseaudio -k
$ pulseaudio -vv
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root priviliges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
D: main.c: Started as real root: no, suid root: yes
I: main.c: We're in the group 'pulse-rt', allowing high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: Giving up CAP_NICE
D: main.c: Can realtime: yes, can high-priority: yes
I: main.c: This is PulseAudio 0.9.13
D: main.c: Compilation host: i386-redhat-linux-gnu
D: main.c: Compilation CFLAGS: -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -Wall -W -Wextra -pedantic -pipe -Wno-long-long -Wvla -Wno-overlength-strings -Wconversion -Wundef -Wformat -Wlogical-op -Wpacked -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wcast-align -Wwrite-strings -Wno-unused-parameter -ffast-math
D: main.c: Running on host: Linux i686 2.6.27-0.398.rc9.fc10.i686 #1 SMP Mon Oct 6 22:23:41 EDT 2008
I: main.c: Page size is 4096 bytes
D: main.c: Compiled with Valgrind support: no
D: main.c: Running in valgrind mode: no
D: main.c: Optimized build: yes
I: main.c: Machine ID is a4d5dc9da1d817d47ee27d4d48a0afaf.
I: main.c: Using runtime directory /home/gronslet/.pulse/a4d5dc9da1d817d47ee27d4d48a0afaf:runtime.
I: main.c: Using state directory /home/gronslet/.pulse.
I: main.c: Running in system mode: no
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: memblock.c: Using shared memory pool with 1024 slots of size 64.0 KiB each, total size is 64.0 MiB
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266d_sound_card_0_alsa_playback_0
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266d_sound_card_0_alsa_capture_0
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266d_sound_card_0_alsa_control__1
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_playback_4
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_capture_3
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_capture_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0 tsched=1'
D: alsa-util.c: Trying front:0...
D: alsa-util.c: Maximum hw buffer size is 371 ms
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
I: module-alsa-sink.c: Successfully enabled timer-based scheduling mode.
I: (alsa-lib)control.c: Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: source.c: Created source 0 "alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0.monitor" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-alsa-sink.c: Using 1 fragments of size 65536 bytes, buffer time is 371.52ms
I: module-alsa-sink.c: Time scheduling watermark is 20.00ms
D: module-alsa-sink.c: hwbuf_unused_frames=0
D: module-alsa-sink.c: setting avail_min=62005
I: module-alsa-sink.c: Volume ranges from 0 to 31.
I: module-alsa-sink.c: Volume ranges from -46.50 dB to 0.00 dB.
I: alsa-util.c: All 2 channels can be mapped to mixer channels.
I: module-alsa-sink.c: Using hardware volume control. Hardware dB scale supported.
D: alsa-util.c: snd_pcm_dump():
D: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
D: alsa-util.c: Its setup is:
D: alsa-util.c:   stream       : PLAYBACK
D: alsa-util.c:   access       : MMAP_INTERLEAVED
D: alsa-util.c:   format       : S16_LE
D: alsa-util.c:   subformat    : STD
D: alsa-util.c:   channels     : 2
D: alsa-util.c:   rate         : 44100
D: alsa-util.c:   exact rate   : 44100 (44100/1)
D: alsa-util.c:   msbits       : 16
D: alsa-util.c:   buffer_size  : 16384
D: alsa-util.c:   period_size  : 16384
D: alsa-util.c:   period_time  : 371519
D: alsa-util.c:   tstamp_mode  : NONE
D: alsa-util.c:   period_step  : 1
D: alsa-util.c:   avail_min    : 62005
D: alsa-util.c:   period_event : 0
D: alsa-util.c:   start_threshold  : -1
D: alsa-util.c:   stop_threshold   : -1
D: alsa-util.c:   silence_threshold: 0
D: alsa-util.c:   silence_size : 0
D: alsa-util.c:   boundary     : 1073741824
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
D: module-alsa-sink.c: Read hardware volume: 0:  69% 1:  69%
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0 tsched=1").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0 tsched=1'
D: alsa-util.c: Trying front:0...
D: alsa-util.c: Maximum hw buffer size is 371 ms
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: module-alsa-source.c: Successfully enabled timer-based scheduling mode.
I: (alsa-lib)control.c: Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-alsa-source.c: Using 1 fragments of size 65536 bytes, buffer time is 371.52ms
I: module-alsa-source.c: Time scheduling watermark is 20.00ms
D: module-alsa-source.c: hwbuf_unused_frames=0
D: module-alsa-source.c: setting avail_min=62005
I: module-alsa-source.c: Volume ranges from 0 to 15.
I: module-alsa-source.c: Volume ranges from 0.00 dB to 22.50 dB.
I: alsa-util.c: All 2 channels can be mapped to mixer channels.
I: module-alsa-source.c: Using hardware volume control. Hardware dB scale supported.
D: alsa-util.c: snd_pcm_dump():
D: alsa-util.c: Hardware PCM card 0 'Intel ICH6' device 0 subdevice 0
D: alsa-util.c: Its setup is:
D: alsa-util.c:   stream       : CAPTURE
D: alsa-util.c:   access       : MMAP_INTERLEAVED
D: alsa-util.c:   format       : S16_LE
D: alsa-util.c:   subformat    : STD
D: alsa-util.c:   channels     : 2
D: alsa-util.c:   rate         : 44100
D: alsa-util.c:   exact rate   : 44100 (44100/1)
D: alsa-util.c:   msbits       : 16
D: alsa-util.c:   buffer_size  : 16384
D: alsa-util.c:   period_size  : 16384
D: alsa-util.c:   period_time  : 371519
D: alsa-util.c:   tstamp_mode  : NONE
D: alsa-util.c:   period_step  : 1
D: alsa-util.c:   avail_min    : 62005
D: alsa-util.c:   period_event : 0
D: alsa-util.c:   start_threshold  : -1
D: alsa-util.c:   stop_threshold   : -1
D: alsa-util.c:   silence_threshold: 0
D: alsa-util.c:   silence_size : 0
D: alsa-util.c:   boundary     : 1073741824
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
D: module-alsa-source.c: Read hardware volume: 0: 100% 1: 100%
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0 tsched=1").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module-stream-restore.c: Sucessfully opened database file '/home/gronslet/.pulse/a4d5dc9da1d817d47ee27d4d48a0afaf:stream-volumes.i386-redhat-linux-gnu.gdbm'.
I: module.c: Loaded "module-stream-restore" (index: #5; argument: "").
I: module-device-restore.c: Sucessfully opened database file '/home/gronslet/.pulse/a4d5dc9da1d817d47ee27d4d48a0afaf:device-volumes.i386-redhat-linux-gnu.gdbm'.
I: module.c: Loaded "module-device-restore" (index: #6; argument: "").
I: module-default-device-restore.c: Restored default sink 'alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0'.
D: core-subscribe.c: Dropped redundant event due to change event.
I: module-default-device-restore.c: Restored default source 'alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0'.
I: module.c: Loaded "module-default-device-restore" (index: #7; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #8; argument: "").
I: module.c: Loaded "module-always-sink" (index: #9; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #10; argument: "").
I: client.c: Created 0 "ConsoleKit Session /org/freedesktop/ConsoleKit/Session2"
D: module-console-kit.c: Added new session /org/freedesktop/ConsoleKit/Session2
I: module.c: Loaded "module-console-kit" (index: #11; argument: "").
I: module.c: Loaded "module-position-event-sounds" (index: #12; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': failure
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
D: module-console-kit.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Sink alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0.monitor idle for too long, suspending ...

------------------------------------------------------------



To put it simple, this renders my laptop useless for playing audio
using headphones, as this pop is harmful for my ears.

I'd be happy to provide more detailed info, please let me know.
Comment 5 Thomas Cameron 2008-10-15 21:16:00 EDT
Per Jeff Bastian's comment, I tested with the following settings:

Sound Events:
Sound playback:  NVidia CK804 with ALC850 NVidia CK804 (OSS)

Music and Movies:
Sound playback:  NVidia CK804 with ALC850 NVidia CK804 (OSS)

Audio Conferencing:
Sound playback:  NVidia CK804 with ALC850 NVidia CK804 (OSS)
Sound capture:  NVidia CK804 with ALC850 NVidia CK804 (OSS)

The random pops and snaps seem to have stopped, but I still get a scratching noise at the beginning of every sound.

I've changed this to a bug against the kernel rather than against pulseaudio, as the sound modules are a part of the kernel.  I don't think this is actually a pulseaudio problem.
Comment 6 John Poelstra 2008-10-17 14:41:30 EDT
adding to "Target" trackers... not sure if that should be Blocker instead.
Comment 7 Bill Nottingham 2008-10-24 16:25:32 EDT
*** Bug 465658 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2008-10-24 16:28:12 EDT
I've been seeing this, but with the current packages:

kernel-2.6.27.3-34.rc1.fc10.x86_64 (Intel HDA)
pulseaudio-0.9.13-4.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.x86_64

I'm not seeing this any more - I can play three songs simultaneously without any crackling. (I do get periodic pauses, though.)
Comment 9 Lennart Poettering 2008-10-24 16:31:07 EDT

*** This bug has been marked as a duplicate of bug 462200 ***