Bug 466878

Summary: Traceback in preupgrade
Product: [Fedora] Fedora Reporter: Răzvan Sandu <razvan.sandu>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: marius.stracna, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-14 12:03:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Răzvan Sandu 2008-10-14 06:38:04 EDT
Description of problem:


I'm trying to upgrade Fedora 9 to Rawhide using preupgrade.

I've only enabled the rawhide and livna-devel official repos, in order to avoid
package conflicts.

However, I got this traceback when running preupgrade:

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 198, in on_assistant_apply
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 206, in _do_main
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 349, in main_preupgrade
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 395, in retrieve_treeinfo
    self.instimage = cp.get('stage2', 'instimage')
  File "/usr/lib/python2.5/ConfigParser.py", line 520, in get
    raise NoOptionError(option, section)
ConfigParser.NoOptionError: No option 'instimage' in section: 'stage2'

Version-Release number of selected component (if applicable):

Comment 1 Will Woods 2008-10-14 12:03:14 EDT
Try preupgrade-0.9.8 from updates-testing.

*** This bug has been marked as a duplicate of bug 459935 ***