Bug 467553

Summary: Update to Eterm 0.9.5-1 breaks text selection (copy and paste)
Product: [Fedora] Fedora Reporter: Tim Becker <tbecker>
Component: etermAssignee: Terje Røsten <terjeros>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 9CC: terjeros
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-13 03:36:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tim Becker 2008-10-18 13:53:28 UTC
Description of problem:
After updating to Eterm 0.9.5-1 text selection is no longer possible.  Upon releasing the mouse button after a text selection the selection disappears and text is not copied.  Eterm 0.9.4-10 works fine.

Version-Release number of selected component (if applicable):
0.9.5-1

How reproducible:
Every time.

Steps to Reproduce:
1.Open an Eterm and select text to copy
2.
3.
  
Actual results:
Text is not highlighted or copied

Expected results:
Text should remain highlighted and copied

Additional info:

Comment 1 Terje Røsten 2008-10-18 18:27:13 UTC
Strange, I not able not reproduce this on 4-5 different systems.

I need more info about your enviroment, are you using GNOME, e16, e or KDE or something different?

X server? ati, nvidia, intel or? locale info would be nice too.
Your system is updated with latest updates?

Does xterm, aterm, rxvt or similar work?

Can you try to reset Eterm to default config (rename .Eterm to
.Eterm.bug-hunting)

Comment 2 Tim Becker 2008-10-18 18:47:08 UTC
My system is updated with the latest updates as of 10/18/09

I am using KDE 4.1 

X server is Intel (945GM)

Xterm works as expected, aterm, rxvt not installed.  konsole works as expected.

Renamed .Eterm to .Eterm-bug  with no effect.

Comment 3 Terje Røsten 2008-11-01 18:17:10 UTC
Thanks for the report Tim. 

I have noe confirmed the following on FC10:

      GNOME    KDE
0.9.4   ok     ok
0.9.5   ok   broken

Will ping upstream about the bug.

Comment 4 Terje Røsten 2008-11-10 15:57:23 UTC
Ok, seems like a patch to fix such problem actually broke it.

Please try the package found here:

  http://terjeros.fedorapeople.org/eterm/

Comment 5 Tim Becker 2008-11-10 18:57:40 UTC
The eterm package at http://terjeros.fedorapeople.org/eterm/ resolve the issue for me.


Thanks!!!!!

Comment 6 Fedora Update System 2008-11-11 18:16:04 UTC
eterm-0.9.5-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/eterm-0.9.5-2.fc9

Comment 7 Fedora Update System 2008-11-11 18:16:07 UTC
eterm-0.9.5-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/eterm-0.9.5-2.fc10

Comment 8 Fedora Update System 2008-11-11 18:16:09 UTC
eterm-0.9.5-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/eterm-0.9.5-2.fc8

Comment 9 Fedora Update System 2008-11-13 03:36:01 UTC
eterm-0.9.5-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-11-13 03:37:13 UTC
eterm-0.9.5-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2008-11-22 16:52:08 UTC
eterm-0.9.5-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.