Bug 467955

Summary: supersede domain-search not working
Product: [Fedora] Fedora Reporter: Levente Farkas <lfarkas>
Component: dhcpAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: dcantrell, wwoods
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-23 16:09:01 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dhclient-wlan0.conf
none
ifcfg-wlan0
none
nm-dhclient-wlan0.conf
none
messages log none

Description Levente Farkas 2008-10-21 16:28:44 EDT
since bug 450042 was closed i open a new bug.
now let's see the facts:-)
in bug 450042 comment #36 said:
------------------------------------
You've got it misconfigured. Check the dhcp-options man page, specifically the
section on "domain-list":

   The domain-list data type specifies a list of domain names, enclosed in
   double quotes and separated by commas ("example.com", "foo.example.com").
------------------------------------
but my files i correct! according to the above quote:
------------------------------------
[root@sas ~]# cat /var/run/nm-dhclient-wlan0.conf
# Created by NetworkManager
# Merged from /etc/dhclient-wlan0.conf

supersede domain-name "lfarkas.org", "int.bppiac.hu", "bppiac.hu", "int.mkk.hu", "mkk.hu", "lenux.hu";
supersede domain-name-servers 192.168.0.2, 192.168.0.1, 192.168.182.1;
------------------------------------
and running:
------------------------------------
[root@sas ~]# ps axufww|grep dhclient|grep -v grep
root      3258  0.0  0.0   2516  1120 ?        S    22:10   0:00  \_ /sbin/dhclient -d -sf /usr/libexec/nm-dhcp-client.action -pf /var/run/dhclient-wlan0.pid -lf /var/run/dhclient-wlan0.lease -cf /var/run/nm-dhclient-wlan0.conf wlan0
------------------------------------
but at the same time in messages log:
------------------------------------
Oct 21 22:10:48 sas dhclient: Internet Systems Consortium DHCP Client 4.0.0
Oct 21 22:10:48 sas dhclient: Copyright 2004-2007 Internet Systems Consortium.
Oct 21 22:10:48 sas dhclient: All rights reserved.
Oct 21 22:10:48 sas dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Oct 21 22:10:48 sas dhclient: 
Oct 21 22:10:48 sas dhclient: /var/run/nm-dhclient-wlan0.conf line 4: semicolon expected.
Oct 21 22:10:48 sas dhclient: supersede domain-name "lfarkas.org",
Oct 21 22:10:48 sas dhclient:                                    ^
Oct 21 22:10:48 sas dhclient: /var/run/nm-dhclient-wlan0.conf line 4: expecting a statement.
Oct 21 22:10:48 sas dhclient: supersede domain-name "lfarkas.org", "int.bppiac.hu", "bppiac.hu", "int.mkk.hu",
Oct 21 22:10:48 sas dhclient: /var/run/nm-dhclient-wlan0.conf line 5: semicolon expected.
Oct 21 22:10:48 sas dhclient: 
Oct 21 22:10:48 sas dhclient: ^
------------------------------------
so either you don't know the proper syntax (and NetworkManager also don't know and generate wrong conf files) or dhclient is don't know his own syntax:
Comment 1 David Cantrell 2008-10-21 17:47:55 EDT
(In reply to comment #0)
> supersede domain-name "lfarkas.org", "int.bppiac.hu", "bppiac.hu",
> "int.mkk.hu", "mkk.hu", "lenux.hu";

We're assuming you have a newline in your configuration file.  'supersede domain-name' settings should all be on one line.  You can tell because of these errors:

> Oct 21 22:10:48 sas dhclient: supersede domain-name "lfarkas.org",
> Oct 21 22:10:48 sas dhclient:                                    ^
> Oct 21 22:10:48 sas dhclient: /var/run/nm-dhclient-wlan0.conf line 4: expecting
> a statement.
> Oct 21 22:10:48 sas dhclient: supersede domain-name "lfarkas.org",
> "int.bppiac.hu", "bppiac.hu", "int.mkk.hu",
> Oct 21 22:10:48 sas dhclient: /var/run/nm-dhclient-wlan0.conf line 5: semicolon
> expected.
> Oct 21 22:10:48 sas dhclient: 
> Oct 21 22:10:48 sas dhclient: ^

dhclient cannot parse that file with a newline.  Fix your configuration file.
Comment 2 Levente Farkas 2008-10-22 06:23:05 EDT
NO!
unfortunately i can't copy'n'paste into bugzilla longer line. it's a two line config file (except the comment and others what NetworkManager paste into it).
please what i show you in one line and _only_ after that response!
Comment 3 David Cantrell 2008-10-22 22:29:42 EDT
Attach your configuration file to this bug so we can see the actual file in use.
Comment 4 Levente Farkas 2008-10-23 09:46:22 EDT
Created attachment 321282 [details]
dhclient-wlan0.conf
Comment 5 Levente Farkas 2008-10-23 09:47:35 EDT
Created attachment 321283 [details]
ifcfg-wlan0
Comment 6 Levente Farkas 2008-10-23 09:48:57 EDT
Created attachment 321285 [details]
nm-dhclient-wlan0.conf
Comment 7 Levente Farkas 2008-10-23 09:49:59 EDT
but imho anybody can test it with his own files...
Comment 8 Levente Farkas 2008-10-23 09:53:14 EDT
Created attachment 321289 [details]
messages log
Comment 9 Will Woods 2008-10-23 11:27:06 EDT
Your dhclient-wlan0.conf is (still) wrong. It says "supersede domain-name" instead of "supersede domain-search". Try changing that and see if it works for you. I've tested it here, and it works fine.

For the record, the SAMPLE section in dhclient.conf(5) also makes this mistake. We should probably fix that.
Comment 10 Levente Farkas 2008-10-23 12:48:46 EDT
that's why i use it.
now it's working.
Comment 11 David Cantrell 2008-10-23 16:09:01 EDT
Since this is a documentation improvement, I am patching it in rawhide only.  The fix will be in dhcp-4.0.0-30.fc10.

I absolutely will not release an F-9 update for this issue because the only issue that has been raised is documentation.  Do not ask for an F-9 update.