Bug 468244

Summary: qpidc package excludes many architectures
Product: [Fedora] Fedora Reporter: Daniel BerrangĂ© <berrange>
Component: qpidcAssignee: Nuno Santos <nsantos>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: aortega, dwmw2, gsim, imain, nsantos
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-08 16:42:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 238953, 179260, 452637    

Description Daniel Berrangé 2008-10-23 18:04:50 UTC
Description of problem:
All fedora packages must be allowed to build on all architectures unless there are clear problems preventing successful build.

qpidc.spec currently has

  ExclusiveArch: i386 i686 x86_64

it appears to build without error on PPC, though the RPM files list seems to have an entry which doesn't exist. This isn't a reason for completely disabling the RPM build on PPC. The ExclusiveArch line should be removed, and the single file be made conditional instead, so the rest of the functionaly is still available.

As per the packaging standards, if there are arch specific problems, a bugzilla ticket must be filed providing details, and made to block the arch specific tracker

Version-Release number of selected component (if applicable):
qpidc-0.3.705289

How reproducible:
Always

Steps to Reproduce:
1. look for PPC build
2.
3.
  
Actual results:
None present

Expected results:
Builds on all architectures

Additional info:

Comment 1 David Woodhouse 2008-11-02 10:31:38 UTC
Adding to FE-ExcludeArch-$ARCH trackers as required.

I'd look through the review to see how this got missed, but for some reason the review bug is private.

Comment 2 Daniel Berrangé 2008-11-02 16:21:05 UTC
The original submission to Fedora included all architectures. It was only switched to exclude non-x86 quite a while after initial submission, in 0.2-16.fc9:

* Thu Jan 03 2008 Nuno Santos <nsantos@redhat.com> - 0.2-16
- limit builds to i386 and x86_64 archs

Comment 3 Nuno Santos 2008-11-03 21:05:09 UTC
At the time there were some missing dependencies on PPC that prevented qpidc from fully building there. It looks like that is not the case any more, so the next update will remove the exclusion.

Comment 4 Nuno Santos 2009-01-08 16:42:28 UTC
qpidc is being build for all archs, the ExcudeArch has been removed.