Bug 468580

Summary: License: export control restrictions violates GNU/FSF recommendation
Product: [Fedora] Fedora Reporter: sergey <sergey_feo>
Component: liberation-fontsAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: medium    
Version: rawhideCC: fonts-bugs, me, petersen
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
URL: https://bugzilla.redhat.com/attachment.cgi?id=295106
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-26 23:13:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 182235    

Description sergey 2008-10-26 08:38:53 EDT
Excuse me for my bad English :-)

Description of problem:

The Liberation fonts are known to most people as "free" now. But license of Liberation fonts contain some restrictions that makes this fonts not free.

Let's see to license of "liberation" fonts - paragraph 5 "Export control":
"[...] As required by U.S. law, Client represents and warrants
that it: (a) [...]; (b)
is not located in a prohibited destination country [...] (currently Cuba, Iran, Iraq, Libya, North Korea, Sudan
and Syria) [...]".
So, please think: Can we say that fonts with such license are free?
Hyperbolic variant A: is the font that can not be legally used at California and Columbia free or not free?
Hyperbolic variant B: is the font that can be used legally only at Moon free or not free?

I understand that Redhat must not break U.S. laws. But it seems that license may not contains such things. Lets see what GNU/FSF writes about it - http://www.gnu.org/philosophy/free-sw.html, paragraph below freedoms list:

"Thus, you should be free to redistribute copies, either with or without modifications, either gratis or charging a fee for distribution, to anyone anywhere".

And so - http://www.gnu.org/philosophy/free-sw.html#exportcontrol:
"Sometimes government export control regulations and trade sanctions can constrain your freedom to distribute copies of programs internationally. Software developers do not have the power to eliminate or override these restrictions, but what they can and must do is refuse to impose them as conditions of use of the program. In this way, the restrictions will not affect activities and people outside the jurisdictions of these governments."

Please accept this GNU/FSF recommendation and exclude export limitations from license if it is possible.

Version-Release number of selected component (if applicable):
1.0-1

How reproducible:
Always

Steps to Reproduce:
1. Download archive from https://bugzilla.redhat.com/attachment.cgi?id=295106
2. Unpack
3. Read file "License.txt", paragraph 5 intently. Imagine that prohibited destination is you home or home of your friend.
  
Actual results:
Fonts is not really free.

Expected results:
Fonts should be free because it was included to Fedora to be free.

Additional info:
-none-
Comment 1 Jens Petersen 2008-10-26 20:23:22 EDT
Reassigning to spot so that Fedora Legal can take care of this.
Comment 2 Tom "spot" Callaway 2008-10-26 23:13:24 EDT
The version you pulled out of bugzilla is a much older revision. The text you're worried about isn't in the latest version of the Liberation Font license:

https://fedorahosted.org/liberation-fonts/browser/trunk/License.txt

Paragraph 5 says (in its entirety):

5. General. If any provision of this agreement is held to be unenforceable, that shall not affect the enforceability of the remaining provisions. This agreement shall be governed by the laws of the State of North Carolina and of the United States, without regard to any conflict of laws provisions, except that the United Nations Convention on the International Sale of Goods shall not apply.

In fact, the wording "destination country" that you quote, never appears in the current license.

The only font package that still is under the old license terms seems to be the Fedora 8 package, definitely not rawhide as you've claimed.

Closing as NOTABUG.
Comment 3 sergey 2008-10-28 13:28:04 EDT
Excuse me for reporting bug for inappropriate fonts version. And thanks for quick detailed answer :-)