Bug 469271

Summary: yum ia64 no longer supports i386/i686/etc.
Product: Red Hat Enterprise Linux 5 Reporter: James Antill <james.antill>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED ERRATA QA Contact: Jan Hutař <jhutar>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.3CC: dkovalsk, jhutar, lockhart, notting, riek, syeghiay
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-20 16:44:30 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description James Antill 2008-10-30 19:31:42 EDT
Description of problem:
 Since yum-3.2.10 or so upstream yum no longer supports anything but ia64 and noarch packages on ia64 (on the advise of Fedora people), but RHEL-5 still ships at least .i386 and .i686 packages in the ia64 RHN channels.

 Changing this is a trivial one line fix, but this BZ is mainly a "which is right" (I'm guessing RHEL/RHN) ... but also so I can get the flags to fix it.
Comment 1 RHEL Product and Program Management 2008-10-30 19:59:28 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 James Antill 2008-10-31 08:52:18 EDT
*** Bug 469343 has been marked as a duplicate of this bug. ***
Comment 3 James Antill 2008-10-31 08:55:14 EDT
 Also with respect to:

diff -u /usr/lib/python2.4/site-packages/rpmUtils/arch.py{.orig,}
--- /usr/lib/python2.4/site-packages/rpmUtils/arch.py.orig 2008-10-31
07:38:13.000000000 -0400
+++ /usr/lib/python2.4/site-packages/rpmUtils/arch.py 2008-10-31
07:38:44.000000000 -0400
@@ -67,7 +67,7 @@
     "sh3": "noarch",

     #itanium
-    "ia64": "noarch",
+    "ia64": "i386",
     }

 def legitMultiArchesInSameLib(arch=None):

...I assume we need the above to be i686 so we can get the glibc/openssl .i686 packages?
Comment 4 Jan Hutař 2008-10-31 09:28:04 EDT
Hello Denis, what are correct secondary archs for ia64 RHEL-5 system? Is i386 and noarch enough?
Thank you in advance,
Jan
Comment 5 Bill Nottingham 2008-10-31 12:24:43 EDT
I'd think just a patch to revert rpmUtils/arch.py to prior should be fine; there's no need to worry about optimizations w.r.t. i686.
Comment 17 errata-xmlrpc 2009-01-20 16:44:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0176.html