Bug 469595

Summary: RFE: Improve support for <othercredit>
Product: [Community] Publican Reporter: David O'Brien <daobrien>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED CURRENTRELEASE QA Contact: Content Services Development <ecs-dev-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.0CC: mmcallis, publican-list
Target Milestone: ---Keywords: Documentation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.39 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-02 19:47:58 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description David O'Brien 2008-11-02 19:11:37 EST
Description of problem:
The use of this tag doesn't break anything, but the output needs to be improved. Currently there is no line break before <email> (or after <contrib> - I'm not sure which).

Version-Release number of selected component (if applicable):
$ rpm -qi publican
Name        : publican
Version     : 0.38
Release     : 0.el5

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
FirstName LastName
Contribname@redhat.com

Expected results:
First Name
Contrib
name@redhat.com

Additional info:
Real example of expected results:

Joe Editor
Technical edit of chapters 3 and 4
jedit@mydomain.com
Comment 1 David O'Brien 2008-11-02 19:22:14 EST
A bit more info:

I tried to use this tag like so:

<othercredit class="technicaleditor">
	<firstname>Joe</firstname>
	<surname>Edit</surname>
	<contrib>Technical edit</contrib>
	<email>jedit@mydomain.com</email>
</othercredit>

I don't know if you would normally modify presentation based on class, I'm just describing how I tried to use it.
Comment 2 Jeff Fearn 2008-11-02 19:47:58 EST
Added rule for .contrib to CSS
Comment 3 Fedora Update System 2008-12-01 00:39:42 EST
publican-0.39-0.fc9,publican-fedora-0.16-0.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/publican-0.39-0.fc9,publican-fedora-0.16-0.fc9
Comment 4 Fedora Update System 2009-01-14 21:56:21 EST
publican-0.39-0.fc9, publican-fedora-0.16-0.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.