Bug 471775

Summary: GPG key error in upgrade.log
Product: [Fedora] Fedora Reporter: Bradley <bbaetz>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: anaconda-maint-list
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-16 00:26:05 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Bradley 2008-11-15 22:46:55 EST
Description of problem:

When upgrading to rawhide (from F9, using preupgrade), upgrade.log starts off with:

Upgrading libgcc-4.3.2-7.x86_64
warning: libgcc-4.3.2-7: Header V3 DSA signature: NOKEY, key ID 4ebfc273
Upgrading setup-2.7.4-1.fc10.noarch
...

Version-Release number of selected component (if applicable):

anaconda-11.4.1.58-1.fc10

(I know it was this version, because I couldn't upgrade until bug 471288 was fixed)

How reproducible:

Didn't try

Steps to Reproduce:
1. Upgrade
2. Check /root/upgrade.log
  
Actual results:

NOKEY error

Expected results:

No error

Additional info:

The keyID matches other packages, and rpm -V doesn't complain after install

[root@plum ~]# rpm -qi libgcc-4.3.2-7.x86_64
Name        : libgcc                       Relocations: (not relocatable)
Version     : 4.3.2                             Vendor: Fedora Project
Release     : 7                             Build Date: Wed 05 Nov 2008 23:19:26 EST
Install Date: Sun 16 Nov 2008 12:17:54 EST      Build Host: x86-7.fedora.phx.redhat.com
Group       : System Environment/Libraries   Source RPM: gcc-4.3.2-7.src.rpm
Size        : 121896                           License: GPLv3+ and GPLv2+ with exceptions
Signature   : DSA/SHA1, Thu 06 Nov 2008 13:17:22 EST, Key ID bf226fcc4ebfc273
Packager    : Fedora Project
URL         : http://gcc.gnu.org
Summary     : GCC version 4.3 shared support library
Description :
This package contains GCC shared support library which is needed
e.g. for exception handling support.
Comment 1 Chris Lumens 2008-11-16 00:26:05 EST

*** This bug has been marked as a duplicate of bug 998 ***