Bug 472176

Summary: [RO] Please backport Romanian language support from Fedora 10 to RHEL 5.2 and up
Product: Red Hat Enterprise Linux 5 Reporter: Răzvan Sandu <razvan.sandu>
Component: distributionAssignee: RHEL Product and Program Management <pm-rhel>
Status: CLOSED WONTFIX QA Contact: Release Test Team <release-test-team>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: alexxed, marius.stracna, syeghiay
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-30 23:05:07 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Răzvan Sandu 2008-11-19 02:01:24 EST
Description of problem:

The now-emerging Fedora 10 is the first version that brings *complete and correct* support for Romanian language, i.e:


- keyboard layouts according to official Romanian national standard (SR 13392:2004) (that is fully compatible with Windows, too);

- keymaps that generate Romanian (UTF-8) diacritics with comma-below, not with cedilla-below (ș ț Ș Ț);

- at least one font that contains correct comma-below glyphs for Romanian, in both X mode and console mode (terminus-font-x11 and terminus-font-console);

- system utilities that "know” about the new settings, during install and afterwards (system-config-keyboard, system-config-language, anaconda, etc.)

- healthy *defaults* in sysconfig tree when an user chooses to install his system in Romanian (secondary keyboard layout with comma-below characters must be the default).


The presence of this national language support in the distro is critical for Romanian users, since there is no other way to generate correctly-written Romanian documents (in old versions, cedilla-below characters were generated).


Please backport ASAP these elements for Romanian language in all Red Hat Enterprise Linux versions that are currently under support (at least 5.2 and up), via online updates.

These should not be treated as an enhancement to current RHEL versions, but as a long-awaited fix for a known bug.

The fix is especially important for the RHEL Desktop version, where documents are actually generated in word-processors and HTML editors.

Please allow as much as possible of these fixes to be integrated upstream, in order to attain the same level of support for Romanian în other non-commercial distros like Debian, Ubuntu, Kiwi Linux, etc.


Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux 5.2 and up.


Actual results:

There is no correct and/or complete support for Romanian language in RHEL, as of November 19, 2008.


Expected results:

Please backport ASAP Romanian language support from Fedora 10 in RHEL, as a bug fix (via online updates).


Additional info:

Please see (partially in Romanian):
http://www.secarica.ro
Comment 1 Subhendu Ghosh 2011-01-30 22:46:58 EST
This enhancement request was evaluated by Red Hat Product Management for inclusion a Red Hat Enterprise Linux major release.

Red Hat does not currently plan to provide this enhanced functionality in the next Red Hat Enterprise Linux major release.

Red Hat values your feedback and will take this enhancement request into consideration for future major releases of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2011-01-30 23:05:07 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.