Bug 472759

Summary: OLPC requirements for xulrunner in Fedora Mainline
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: xulrunnerAssignee: Christopher Aillon <caillon>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 11CC: caillon, gecko-bugs-nobody, johnp, sascha-web-bugzilla.redhat.com, stransky, walters
Target Milestone: ---Keywords: Reopened
Target Release: ---Flags: dennis: fedora-cvs-
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-03 12:16:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 462625    

Description Peter Robinson 2008-11-24 12:48:47 UTC
Please create OLPC-4 branch for xulrunner

Comment 1 Dennis Gilmore 2008-11-25 16:26:07 UTC
why?  there really is no reason for it. xulrunner in F-10 has  pyxpcom built. OLPC can and should use the Fedora branch.

Comment 2 Peter Robinson 2008-11-25 16:35:49 UTC
If you look at the OLPC-3 branch there is also a number of patches to XULrunner to do with disable of default themes, and removing libgnome and gnomevfs. 

I'm sure that one day they will follow the gnome upstream and migrate to gio and all the new gnome stuff but its not in for 3.0 as far as I can see and I'm not sure its even there for 3.1. I'm investigating too see if the other patches are upstreamable and if the developer has filed patches in b.m.o for them but I'm not there yet. Believe me I want upstream OLPC everything ASAP :)

See the diff.

[perobinson@neo xulrunner]$ diff -u F-10/xulrunner.spec OLPC-3/xulrunner.spec 
--- F-10/xulrunner.spec	2008-11-12 22:37:53.000000000 +0000
+++ OLPC-3/xulrunner.spec	2008-10-07 14:48:11.000000000 +0100
@@ -7,8 +7,8 @@
 
 Summary:        XUL Runtime for Gecko Applications
 Name:           xulrunner
-Version:        1.9.0.4
-Release:        1%{?dist}
+Version:        1.9.0.2
+Release:        2%{?dist}
 URL:            http://developer.mozilla.org/En/XULRunner
 License:        MPLv1.1 or GPLv2+ or LGPLv2+
 Group:          Applications/Internet
@@ -32,6 +32,11 @@
 Patch26:        mozilla-ps-pdf-simplify-operators.patch
 Patch27:        mozilla-ssl-exception.patch
 
+# OLPC
+Patch201:       xulrunner-olpc-no-native-theme.patch
+Patch202:       xulrunner-olpc-pre-dpi.patch
+Patch204:       xulrunner-olpc-xds.patch
+Patch205:	xulrunner-olpc-perms.patch
 
 # ---------------------------------------------------
 
@@ -47,9 +52,7 @@
 BuildRequires:  lcms-devel >= 1.17
 BuildRequires:  libIDL-devel
 BuildRequires:  gtk2-devel
-BuildRequires:  gnome-vfs2-devel
-BuildRequires:  libgnome-devel
-BuildRequires:  libgnomeui-devel
+BuildRequires:  dbus-glib-devel
 BuildRequires:  krb5-devel
 BuildRequires:  pango-devel
 BuildRequires:  freetype-devel >= 2.1.9
@@ -128,7 +131,12 @@
 %patch10 -p1 -b .pk
 
 %patch26 -p1 -b .ps-pdf-simplify-operators
+#%patch27 -p1 -b .ssl-exception
 
+%patch201 -p0 -b .no-native-theme
+%patch202 -p0 -b .dpi
+%patch204 -p0 -b .xds
+%patch205 -p0 -b .perms
 
 %{__rm} -f .mozconfig
 %{__cp} %{SOURCE10} .mozconfig

Comment 3 Dennis Gilmore 2008-11-25 18:11:06 UTC
Please send the patches upstream and to Chris with explanations as to what they do and why they are needed.

Comment 4 Christopher Aillon 2008-11-25 21:40:09 UTC
And at the bare minimum, I strongly suggest getting explicit approval from upstream (Mozilla) for these patches.  We have a great relationship with Mozilla which is good when we need to seek changes for things such as the EULA issue.  Just throwing in patches without either my or upstream's approval is rather harmful for everyone involved.  Getting approval will at least put it through some review process to make sure the patches don't break something else, which will benefit OLPC and its consumers and its upstream Fedora.  If an OLPC patch ends up breaking things, it makes both Mozilla and Fedora look bad.

Comment 5 Peter Robinson 2008-11-25 21:52:09 UTC
OK, this has been highlighted this with Simon (via Danial) and I'll ask him to take that forward for upstream. I'm no real developer, more a Fedora packager working with jkatz and others to help OLPC get things as mainstream as possible and help with the packaging side of things so their dev's can develop.

Christopher, do you know what the Moz plans are with gio and what what extras libgnome gives to Fedora over mainline building without libgnome and friends, or if FF 3.1 or XL 1.9.1 will help with moving away from libgnome like gnome upstream is doing? Or even when there might be a 1.9.1 beta that they can test to see if that improves things :-)

Comment 6 Bug Zapper 2008-11-26 05:51:19 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Peter Robinson 2008-11-26 20:22:40 UTC
The OLPC Browser people are going to investigate further over the next couple of days to review requirements and file bugs upstream as necessary. I've filed a OLPC tracking bug which I've linked to the external bug tracker on this bug. I think we should leave this one open for tracking the Fedora requirements.

Comment 8 Bug Zapper 2009-06-09 09:54:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Peter Robinson 2009-08-03 12:16:12 UTC
Closing as it looks like its all OK with xulrunner 1.9.1 appart from the requirement on gnome-vfs and there's not much we can do about that atm.