Bug 47531

Summary: when using enscript to print a file it prints pages of garbage.
Product: [Retired] Red Hat Linux Reporter: Need Real Name <mike>
Component: printconfAssignee: Tim Waugh <twaugh>
Status: CLOSED CANTFIX QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 7.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i586   
OS: Linux   
URL: HP932C DJ Text prints, Postscript Prints garbage
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-16 12:36:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
Requested /etc/alchemist/namespace/printconf/local.adl file none

Description Need Real Name 2001-07-05 19:55:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Good: Configured my Samba connected HP932C with printconf-gui tool.  Good: 
Tested text print and it worked fine. 
Bad: Used enscript and the printer started printing pages of garbage.  
Bad: I tried all 4 GS drivers cdj550, cdj880, hpdj and stpr ( stpr blew up 
and spit out a dump). 
Good: I then manually created the enscript ps file, fed that into gs and 
then used smbclient to print the file, that worked.  I tried both cdj550 
and cdj880, they both worked fine when the printconf stuff was by-passed.  
Bad: I was running Red Hat 7.0 and upgraded it to 7.1.  
Good: I didn't have any problems printing or using enscript under 7.0.  
Bad: This all started with 7.1.

How reproducible:

Steps to Reproduce:
1.enscript fn

Actual Results:  Printer spit out pages of garbage

Expected Results:  File printed on the printer

Additional info:

Upgraded from Red Hat 7.0 to Red Hat 7.1
Verified that Gostscript will process the postscript file correctly when 
removing printconf from the process.
1) Created a ps file using enscript
2) Converted for printing using gs
3) Printed the file successfully using smbclient print command
Comment 1 Crutcher Dunnavant 2001-08-06 17:21:24 EDT
can you attach the following file?

Comment 2 Need Real Name 2001-08-06 20:43:00 EDT
Created attachment 26535 [details]
Requested /etc/alchemist/namespace/printconf/local.adl file
Comment 3 Tim Waugh 2002-01-10 07:40:04 EST
Does this problem still happen now, or did it get solved?
Comment 4 Need Real Name 2002-01-12 11:03:22 EST
Yes 6 months later, nothing has been solved.  I supplied some information 
several months ago but am still waiting for a FIX!
Comment 5 Tim Waugh 2002-01-18 16:41:46 EST
Do the packages at <ftp://people.redhat.com/twaugh/errata-candidate/> help?
Comment 6 Tim Waugh 2002-01-23 11:52:16 EST
Can someone experiencing this problem please attach the status.<queuename>
file from the spool directory?
Comment 7 Tim Waugh 2005-09-16 12:36:14 EDT
No feedback.