Bug 476379

Summary: vol_id is not found in $PATH contrary to vol_id(8)
Product: [Fedora] Fedora Reporter: D. Hugh Redelmeier <hugh>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 10CC: harald, hugh, kay.sievers
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-20 06:39:04 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description D. Hugh Redelmeier 2008-12-13 16:18:55 EST
Description of problem:
"vol_id" as a command won't work but "/lib/udev/vol_id" does.
This is surprising given the man page suggests that it should.

Version-Release number of selected component (if applicable):
udev-127-3.fc10.x86_64


How reproducible:
Always

Steps to Reproduce:
1.type "vol_id"

  
Actual results:
-bash: vol_id: command not found


Expected results:
it should run.

Additional info:
The manpage synopsis ought to include the full path to be program.
Or the binary could be moved to a bin directory (Ubuntu 8.10 has it in /sbin).

This may apply to the other programs living in /lib/vol.
Comment 1 Harald Hoyer 2008-12-15 10:55:05 EST
Kay, should we provide a symlink or do you add the full path to the manpage?
Comment 2 Kay Sievers 2008-12-15 11:43:12 EST
Everything in /lib/udev/ is a private implementation to udev, and not supposed to be called by anything else. Sure, it does not hurt using it, but nothing can rely on anything here to always be there.

In fact, in the next months we plan to delete /lib/udev/vol_id without further notice, as soon as we successfully merged libvolume_id and libblkid to a single filesystem probing library.

Creating symlinks or moving things from /lib/udev to /sbin is plain wrong for the mentioned reason.

I have no problem just deleting the man pages, if that causes misunderstandings for anybody.
Comment 3 D. Hugh Redelmeier 2008-12-15 13:50:11 EST
What is the stable / "official" way of finding UUIDs?  Googling got me to vol_id.  "man -k uuid" lists only vol_id(8).

Why did I want to know a partition's UUID?  To manually create fstab entries.

I'm all for standard, stable, documented, public interfaces.  Each of those attributes is important.

FWIW Ubuntu 8.10 has a symlink from /sbin/vol_id to /lib/udev/vol_id.
Comment 4 Kay Sievers 2008-12-15 17:38:14 EST
(In reply to comment #3)
> What is the stable / "official" way of finding UUIDs?  Googling got me to
> vol_id.  "man -k uuid" lists only vol_id(8).

In the future it will be /sbin/blkid, if all works out as planned.

> Why did I want to know a partition's UUID?  To manually create fstab entries.
> 
> I'm all for standard, stable, documented, public interfaces.  Each of those
> attributes is important.

Sure, I understand. But the private udev helper vol_id is not such an interface, you can use it but not depend on it beeing there in a future release. I hope /sbin/blkid will be fine after the merge.

> FWIW Ubuntu 8.10 has a symlink from /sbin/vol_id to /lib/udev/vol_id.

It was in /sbin when we started with this, but it moved to the private directory long ago for the reason it may change or even go away without notice. Creating such a symlink is not the right thing.