This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours

Bug 476521

Summary: Coredump on start when no kvm modules is loaded
Product: [Fedora] Fedora Reporter: Zdenek Kabelac <zkabelac>
Component: qemuAssignee: Glauber Costa <gcosta>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: berrange, clalance, dwmw2, gcosta, markmc, quintela, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-20 13:34:00 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Zdenek Kabelac 2008-12-15 07:44:18 EST
Description of problem:

I've just noticed that qemu-kvm generates coredump when it's started and kvm module is not inserted in memory - I think some nice error message would be better here:

#0  0x0000000000536851 in kvm_irqchip_in_kernel (kvm=0x0) at libkvm.c:1030
1030		return kvm->irqchip_in_kernel;
#1  0x0000000000463f3c in apic_init_ipi (s=0xc56c30) at /usr/src/debug/kvm-79/qemu/hw/apic.c:439
#2  0x0000000000464edc in apic_reset (opaque=0x0) at /usr/src/debug/kvm-79/qemu/hw/apic.c:952
#3  0x0000000000464f98 in apic_init (env=0xc5c010) at /usr/src/debug/kvm-79/qemu/hw/apic.c:995
#4  0x00000000004495f9 in pc_new_cpu (cpu=1, cpu_model=<value optimized out>, pci_enabled=1)
    at /usr/src/debug/kvm-79/qemu/hw/pc.c:793
#5  0x00000000004496e4 in pc_init1 (ram_size=<value optimized out>, vga_ram_size=16777216, 
    boot_device=0x538709 "cad", ds=0xb48e20, kernel_filename=0x0, kernel_cmdline=0x57294b "", 
    initrd_filename=0x0, pci_enabled=1, cpu_model=0x563fb6 "qemu64")
    at /usr/src/debug/kvm-79/qemu/hw/pc.c:839
#6  0x000000000044b0f4 in pc_init_pci (ram_size=0, vga_ram_size=68, 
    boot_device=0x4 <Address 0x4 out of bounds>, ds=0x44, 
    kernel_filename=0x78 <Address 0x78 out of bounds>, 
    kernel_cmdline=0x200000 <Address 0x200000 out of bounds>, initrd_filename=0x0, cpu_model=0x0)
    at /usr/src/debug/kvm-79/qemu/hw/pc.c:1211
#7  0x000000000040e0f8 in main (argc=<value optimized out>, argv=0x7fff68fb0448)
    at /usr/src/debug/kvm-79/qemu/vl.c:6870


Version-Release number of selected component (if applicable):
kvm-79-1.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. do not load  kvm modules before start of qemu-kvm
2. start qemu-kvm
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2009-03-11 08:38:44 EDT
Reassigning: The kvm package no longer exists in rawhide/F11, since it is now part of 'qemu'.
Comment 2 Mark McLoughlin 2009-03-20 13:34:00 EDT
This looks like a plausible fix:

  http://git.kernel.org/?p=linux/kernel/git/avi/kvm-userspace.git;a=commitdiff;h=16558b080d

Was in kvm-80, so closing as fixed in rawhide