This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 477025

Summary: autostart vm doesn't work
Product: [Fedora] Fedora Reporter: Michael J. Chudobiak <mjc>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 10CC: berrange, clalance, crobinso, gerd, markmc, veillard, virt-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-11 14:11:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Michael J. Chudobiak 2008-12-18 13:32:33 EST
My libvirtd service starts fine, but my VM does not auto-start, even though the "autostart" option is enabled.

It used to work.

Starting it manually gives this:

[root@xena ~]# libvirtd /etc/libvirt/qemu/MikeWindows.xml
libvir: error : invalid connection pointer in virNetworkLookupByName
libvir: QEMU error : internal error Network 'default' not found
Failed to autostart VM 'MikeWindows': internal error Network 'default' not found

I am using the default network setup.

This was also reported to the libvirt mailing list by someone else:

http://www.mail-archive.com/libvir-list@redhat.com/msg09937.html

The VM starts up fine once libvirtd is up and you use the Virtual Machine Manager to start the VM, manually.

This is crippling for my users, since root access is required to start the VMs manually.


- Mike
Comment 1 Michael J. Chudobiak 2008-12-19 11:21:36 EST
My workaround for now is to do this:

chkconfig --level 0123456 libvirtd off

and add this to root's crontab:

@reboot /sbin/service libvirtd start; /bin/sleep 10; /usr/bin/virsh start MikeWindows

- Mike
Comment 2 Gerd v. Egidy 2008-12-20 16:07:26 EST
To fix this you need
- either the two patches that were posted by me in the thread mentioned above
or
- current libvirt cvs (which contains my patches with some documentation etc. added)
Comment 3 Mark McLoughlin 2009-01-21 04:39:32 EST
Here's the fix committed to CVS:

  http://git.et.redhat.com/?p=libvirt.git;a=commitdiff;h=4e64546fa7

This was in 0.5.1, so closing the bug
Comment 4 Michael J. Chudobiak 2009-01-21 09:51:46 EST
Re-opening bug, because it still doesn't work:

[root@xena ~]# rpm -qa | grep libvirt
libvirt-0.5.1-2.fc10.x86_64
libvirt-python-0.5.1-2.fc10.x86_64

[root@xena ~]# libvirtd /etc/libvirt/qemu/MikeWindows.xml
libvir: error : invalid connection pointer in virNetworkLookupByName
libvir: QEMU error : internal error Network 'default' not found
Failed to autostart VM 'MikeWindows': internal error Network 'default' not found
Comment 5 Cole Robinson 2009-01-23 15:49:33 EST
I think this cset is the needed fix:

http://git.et.redhat.com/?p=libvirt.git;a=commit;h=b6e3cbc6656a0487d7662ca7cd4cbf80e5e88eaf

This landed shortly after 0.5.1, so it wouldn't be in f10 yet. It affects autostarting VMs which use virtual networking.
Comment 6 Cole Robinson 2009-02-16 09:34:11 EST
Pretty certain this is fixed in 0.6.0, so moving to POST.
Comment 7 Daniel Berrange 2009-03-10 08:33:02 EDT
This is available in F10 updates-testing now, 0.6.1 release
Comment 8 Fedora Update System 2009-03-11 13:59:14 EDT
libvirt-0.6.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libvirt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2396
Comment 9 Michael J. Chudobiak 2009-03-11 14:11:41 EDT
Confirmed OK with libvirt-0.6.1-1.fc10.x86_64.

Thanks!

Closing bug.