Bug 4773

Summary: Installs to the wrong partition on a slave ide disk (??)
Product: [Retired] Red Hat Linux Reporter: matti
Component: installerAssignee: Jay Turner <jturner>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-01 12:54:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description matti 1999-08-30 00:08:47 UTC
I made a ext2 and swap partition in the beginning of my
slave ide harddisk with partition magic 4. Diskdruid
reported the ext2 disk as hdb6 and the swap as hdb7. When i
choosed to insall to hdb6 it tried to install to hdb8 and
destroyed the fat table and I lost everything on that
partition.
The same thing happened today when i tried it again.

When i let diskdruid make the partition it calls it hdb2
and messes up the partition table on the disk so no other
operating system can read it.

The disk is the slave disk on the primary ide controller.

Comment 1 Jay Turner 1999-09-01 12:54:59 UTC
Disk Druid tends to make assumptions about the geometry of the drive
that you are installing to.  If you want specific partitions in
specific places (you know that you want to create /dev/hdb8 for
example) then I would recommend that you use fdisk to partition your
drives.  Fdisk allows you to specify the exact partition number that
you are trying to create.