Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.

Bug 477752

Summary: virt-install doesn't know to use virtio for RHEL5.3
Product: [Fedora] Fedora Reporter: Mark McLoughlin <markmc>
Component: python-virtinstAssignee: Daniel Berrange <berrange>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 10CC: berrange, crobinso, psj, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-30 02:58:47 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 480594    

Description Mark McLoughlin 2008-12-23 05:48:29 EST
In order to install RHEL5.3 using virtio, you have to select Fedora 10 as the OS type
Comment 1 Cole Robinson 2008-12-23 10:16:22 EST
This falls in with the general need for more finegrained distro metadata (RHEL5 doesn't cut it when we may need to distinguish between 5.0, 5.1, etc.)

Current upstream has a 'Generic Virtio' option which is better than selecting Fedora10 but not the correct fix.
Comment 2 Mark McLoughlin 2009-04-30 02:58:47 EDT
Okay, --os-variant=virtio26 is good enough for this. Closing
Comment 3 Mark McLoughlin 2009-11-19 10:29:10 EST
*** Bug 537707 has been marked as a duplicate of this bug. ***
Comment 4 Cole Robinson 2009-12-07 13:01:09 EST
Even though it's a bit hokey to have a RHEL5 and a RHEL5.4+ option, we have someone working on a proper os dictionary and API which will expose much finer grained OS entries like RHEL5.0 RHEL5.1 RHEL5.2 etc. Since we will eventually have a specific 5.4 entry, I figured it doesn't hurt to do now (since it has been requested enough). So there is now a rhel5.4 entry upstream (and in rawhide, f12 updates-testing)