This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 479772

Summary: KVM Version not Returning
Product: [Fedora] Fedora Reporter: aaron.moate
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 11CC: aaron.moate, berrange, clalance, crobinso, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-04 11:17:23 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description aaron.moate 2009-01-12 19:04:27 EST
Description of problem:
qemudExtractVersion() in qemu_conf will not get the KVM hypervisor's version if /usr/bin/qemu does not exist (because it is hard-wired to search for a capability with an os_type of 'hvm', an arch of 'i686', and a domain of 'qemu').  The capability does not exist since /usr/bin/qemu does not exist, and even if the arch x86_64 capability was selected, /usr/bin/qemu-system-x86_64 does not exist (/usr/local/bin/qemu-system-x86_864 does).  If 32-bit qemu existed at /usr/bin/qemu, it would not reflect the version of KVM. 

Version-Release number of selected component (if applicable):
libvirt: LIBVIRT_0_5_1-146-gb035434
kvm: kvm-81
linux: 2.6.28-rc8-00043-ga3dd154-dirty
qemu: Not Installed

How reproducible:
Very

Steps to Reproduce:
1.Run libvirtd without the /usr/bin/qemu (make sure it doesn't exist)
2.Run 'virt version'
  
Actual results:
Compiled against library: libvir 0.5.1
Using library: libvir 0.5.1
Using API: QEMU 0.5.1
libvir: Remote error : library function returned error but did not set virterror
error: failed to get the hypervisor version

Expected results:
Compiled against library: libvir 0.5.1
Using library: libvir 0.5.1
Using API: QEMU 0.5.1
Running hypervisor: QEMU 0.9.1


Additional info:
A temporary fix for the bug is:
ln -svf /usr/local/bin/qemu-system-x86_64 /usr/bin/qemu
Comment 1 Daniel Berrange 2009-03-20 09:05:23 EDT
Should be fixed upstream with this:

http://www.redhat.com/archives/libvir-list/2009-March/msg00281.html
Comment 2 Bug Zapper 2009-06-09 06:41:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Daniel Berrange 2009-08-04 11:17:23 EDT
This was fixed in the libvirt available at time of F11 GA