Bug 481151

Summary: ntp rpm verification fails on /etc/ntp.conf
Product: Red Hat Enterprise Linux 5 Reporter: Karel Volný <kvolny>
Component: ntpAssignee: Miroslav Lichvar <mlichvar>
Status: CLOSED ERRATA QA Contact: Martin Cermak <mcermak>
Severity: low Docs Contact:
Priority: low    
Version: 5.3CC: azelinka, mcermak, ovasik
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Prior to this update, verifying the ntp package with the "rpm -V" command failed on the package configuration file if the configuration file had changed. However, changes to the configuration file should not impact the verification test. This update adapts the spec file and the package verify test passes successfully.
Story Points: ---
Clone Of:
: 591924 (view as bug list) Environment:
Last Closed: 2011-07-21 02:42:18 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Karel Volný 2009-01-22 08:49:26 EST
Description of problem:
rpm verify test of the package ntp fails on its configuration file /etc/ntp.conf

but this file may be automagically changed by dhclient-script which is the default configuration, and so it could not be expected that it will match the package's version

Version-Release number of selected component (if applicable):
ntp-4.2.2p1-9.el5_3.1

How reproducible:
always (on systems where dhclient can set ntp configuration)

Steps to Reproduce:
1. rpm -V ntp
  
Actual results:
S.5....T  c /etc/ntp.conf

Expected results:
(no error output)

Additional info:
I propose changing the corresponding .spec line to:
%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ntp.conf

the issue is present also on RHEL-4
Comment 3 RHEL Product and Program Management 2010-08-09 15:09:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 15:19:26 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 18:13:46 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 11 Eva Kopalova 2011-06-30 08:43:10 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, verifying the ntp package with the "rpm -V" command failed on the package configuration file if the configuration file had changed. However, changes to the configuration file should not impact the verification test. This update adapts the spec file and the package verify test passes successfully.
Comment 12 errata-xmlrpc 2011-07-21 02:42:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0980.html