Bug 483375

Summary: -o nolock is ignored. Cannot mount without rpc.statd running
Product: [Fedora] Fedora Reporter: Jesse Keating <jkeating>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: dcantrell, markmc, steved, wtogami
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-06 12:05:57 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 476773    

Description Jesse Keating 2009-01-31 02:05:12 EST
When attempting to install via NFS, all NFS mount attempts error with: 
mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.

The mount command was:
mount.nfs reducio:/srv/pungi/f11-alpha.rc6/11-Alpha/Fedora/x86_64/os /mnt/source -o nolock

This makes it impossible to install via nfs.  This is with nfs-utils-1.1.4-14.fc11
Comment 1 Jesse Keating 2009-01-31 02:08:04 EST
Reverting to nfs-utils-1.1.4-12.fc11 resolves this.
Comment 2 Warren Togami 2009-01-31 02:32:19 EST
Although it reintroduced the worst part of Bug #480420 and Bug #480223.
People should be aware that NFS as a server in F11 Alpha is broken.
That is all.
Comment 3 Steve Dickson 2009-01-31 07:00:14 EST

*** This bug has been marked as a duplicate of bug 480223 ***
Comment 4 Steve Dickson 2009-01-31 14:09:19 EST
reopening since this bug is not the same problem as bz480223
Comment 5 Mark McLoughlin 2009-02-06 11:47:50 EST
Was this fixed by 1.1.4-16?

* Sat Jan 31 2009 Steve Dickson <steved@redhat.com> 1.1.4-16
- Fixed typo in -mount-textbased.patch (bz 483375)
Comment 6 Jesse Keating 2009-02-06 12:05:57 EST
Yes, forgot to close.