Bug 483516

Summary: Editor tag presentation
Product: [Community] Publican Reporter: Dani Coulson <dcoulson>
Component: publicanAssignee: Jeff Fearn <jfearn>
Status: CLOSED NOTABUG QA Contact: Content Services Development <ecs-dev-list>
Severity: low Docs Contact:
Priority: low    
Version: 2.0CC: dcoulson, mmcallis, publican-list
Target Milestone: ---Keywords: Documentation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-25 00:02:45 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
screenshot none

Description Dani Coulson 2009-02-01 21:24:11 EST
When the editor tag is used in Author_Group.xml in a branded book, it appears to keep the default publican presentation (attached screenshot).

<authorgroup>
  <author>
    <firstname>Firstname</firstname>
    <surname>Surname</surname>
    <affiliation>
      <orgname>Red Hat</orgname>
      <orgdiv></orgdiv>
    </affiliation>
    <email></email>
  </author>
  <editor>
    <firstname>Firstname</firstname>
    <surname>Surname</surname>
    <affiliation>
      <orgname>Red Hat</orgname>
      <orgdiv></orgdiv>
    </affiliation>
    <email></email>
        </editor>
</authorgroup>
Comment 1 Dani Coulson 2009-02-01 21:25:14 EST
Created attachment 330575 [details]
screenshot
Comment 2 Jeff Fearn 2009-02-01 21:51:38 EST
There is a good reason the default template for bug reports uses the format it does. It's so developers have useful information when trying to track down bugs. A snippet of DocBook isn't very useful if it works for me and gives me no information I can use to narrow down what the problem could be.

This works fine for me on latest publican and Red Hat brand when compiling the publican Users_Guide with: make BRAND=RedHat html-en-US

You can check the users guide out and test this if you want.

svn co http://svn.fedorahosted.org/svn/publican/trunk/publican/content/docs
Comment 3 Dani Coulson 2009-02-02 00:21:32 EST
Description of problem:
The presentation of the information within the editor tag does not appear consistent with the rest of the Red Hat brand.

Version-Release number of selected component (if applicable):
publican-0.41-3.el5

How reproducible:
All four documents I am currently working on look like this when I build them.

Steps to Reproduce:
1. Go to repo I am working in (I will send you the address via email)
2. Build the book
3. View the html version index page.
  
Actual results:
Information within the editor tag is blue (which is similar to the publican default colours)

Expected results:
I would expect that it should be red (the same colour as as the info in the author tag).

Additional info:
The book had previously been built with the Red Hat brand without any problems. I added the editor tag to author_group and it appears in blue instead of red as I would expect.
Comment 4 Dani Coulson 2009-02-02 22:39:21 EST
Additional info:

It appears that everything in the <editor> tag is a mailto:. I can click anywhere (including "Edited by", orgname & orgdiv) and it will compose a new email.
Comment 5 Jeff Fearn 2009-02-02 23:05:01 EST
This issue is related to the empty email tag in the author before the editor. Adding content to the email tag or removing the email tag prevents this issue from occurring.

The easiest way around this is to not include tags you aren't actually using, I'm not sure if it's advisable to handle this pragmatically.