Bug 483840

Summary: dead keys does not work in abnt2 keyboard
Product: [Fedora] Fedora Reporter: Marcus Alves Grando <marcus>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 10CC: arne_woerner, control-center-maint, i18n-bugs, krh, luisgarrido, rstrode, tagoh, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.105.1-4.fc10 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-27 10:53:30 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
xev test case
none
Xorg log none

Description Marcus Alves Grando 2009-02-03 15:52:23 EST
Created attachment 330777 [details]
xev test case

Hello,

I've installed Fedora 10 and update all rpms. After that I test accents and accents using dead keys does not work in xorg applications (xterm, rxvt-unicode, etc).

Test case: `+a ^+e "+u
Actual result: aeu
Expected result: àêü

For gnome or gtk applications works fine.

$ rpm -qa | grep keyboard
system-config-keyboard-1.2.15-4.fc10.noarch
xkeyboard-config-1.4-6.fc10.noarch
xorg-x11-drv-keyboard-1.3.2-1.fc10.i386
$ cat /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="br-abnt2"
LAYOUT="br"
MODEL="abnt2"
OPTIONS=""
VARIANT=""

Some idea?
Comment 1 Marcus Alves Grando 2009-02-03 15:53:32 EST
Created attachment 330778 [details]
Xorg log
Comment 2 Peter Hutterer 2009-02-08 18:29:11 EST
does it work if you run setxkbmap -layout br -model abnt2 once the server is running?
Comment 3 Marcus Alves Grando 2009-02-09 08:28:50 EST
(In reply to comment #2)
> does it work if you run setxkbmap -layout br -model abnt2 once the server is
> running?

No. Works worst. Now deadkeys not work after character. I need to include a space.

Regards
Comment 4 Marcus Alves Grando 2009-02-26 18:39:24 EST
ping
Comment 5 Peter Hutterer 2009-03-02 23:36:48 EST
Please try the following:
- sudo stop prefdm 
  this shuts down your desktop session and drops you onto a vt
- log in
- xinit -- 
  This starts a plain X session, make sure you have xterm installed.
- move the cursor over the xterm
- does you keyboard layout work here?
- if not, run "setxkbmap -layout br -model abnt2"
  You should now have the abnt2 model loaded, does it work?
- ctrl+D/exit in the xterm shuts down the server. sudo start prefdm starts gdm.

I tried it here and it seems something in gnome interferes, but then my knowledge of br layouts is a bit rusty :)
Comment 6 Marcus Alves Grando 2009-03-03 09:24:09 EST
(In reply to comment #5)
> Please try the following:
> - sudo stop prefdm 
>   this shuts down your desktop session and drops you onto a vt
> - log in
> - xinit -- 
>   This starts a plain X session, make sure you have xterm installed.
> - move the cursor over the xterm
> - does you keyboard layout work here?

Yes. Works fine. Can you change to right category?

Regards
Comment 7 Peter Hutterer 2009-03-03 17:58:12 EST
ok, so it's something in gnome. do you have gnome configured to use the Brazilian layout? If so, does it work fine then?

F10 has a bit of a conflict between what's coming from HAL, from gdm and whats configured in gnome. This is (mostly) gone in F11, so the best solution for you may be to just configure it in the keyboard settings dialog.
Comment 8 Marcus Alves Grando 2009-03-03 18:09:27 EST
(In reply to comment #7)
> ok, so it's something in gnome. do you have gnome configured to use the
> Brazilian layout? If so, does it work fine then?
> 
> F10 has a bit of a conflict between what's coming from HAL, from gdm and whats
> configured in gnome. This is (mostly) gone in F11, so the best solution for you
> may be to just configure it in the keyboard settings dialog.

It's already configured in gnome, but does not work.

$ gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [br]
 model = abnt2
 options = [grp	grp:shift_caps_toggle]

I've tried with SCIM input method and works fine. Default method does not work.

Regards
Comment 9 Peter Hutterer 2009-03-09 18:32:18 EDT
reassigning to control-center

it might be good to get the output of xprop -root | grep XKB too
Comment 10 Marcus Alves Grando 2009-03-10 20:25:44 EDT
(In reply to comment #9)
> reassigning to control-center
> 
> it might be good to get the output of xprop -root | grep XKB too  

$ xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "evdev", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "precision_m", "br", "", "grp:alts_toggle"
Comment 11 Akira TAGOH 2009-03-12 23:22:24 EDT
From what the original reporter said at https://bugzilla.redhat.com/show_bug.cgi?id=485595#c11, reassigning
Comment 12 Akira TAGOH 2009-03-13 13:54:22 EDT
I've built testing package. this issue should be gone with it.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1240285
Comment 13 Marcus Alves Grando 2009-03-13 16:45:59 EDT
Yes. Now works fine. Thanks Akira.

Regards
Comment 14 Akira TAGOH 2009-03-17 02:27:06 EDT
*** Bug 488713 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2009-03-17 02:55:16 EDT
imsettings-0.105.1-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/imsettings-0.105.1-4.fc10
Comment 16 Fedora Update System 2009-03-18 15:13:48 EDT
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update imsettings'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2843
Comment 17 Luis Garrido 2009-03-25 20:32:18 EDT
I am having a similar problem but with the Spanish layout, updating imsettings didn't have any effect. Dead keys work fine on gtk applications and xterm but won't work on qt or java based apps.
Comment 18 Luis Garrido 2009-03-25 20:46:28 EDT
Update: enabling input method feature solves the issue.

System->Preferences->Personal->Input Method

I don't know whether having updated imsettings had any influence.

Cheers.
Comment 19 Akira TAGOH 2009-03-25 22:06:01 EDT
(In reply to comment #17)
> I am having a similar problem but with the Spanish layout, updating imsettings
> didn't have any effect. Dead keys work fine on gtk applications and xterm but
> won't work on qt or java based apps.  

Well, basically there are no difference how it works on xterm, qt and java. these uses XIM. have you tried to restart your desktop or reboot? if not, please try again after disabling IM from im-chooser and restart your desktop.
Comment 20 Fedora Update System 2009-03-27 10:52:56 EDT
imsettings-0.105.1-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.