Bug 486751

Summary: umount.nfs: error message when unmounting mount done with vers= option
Product: [Fedora] Fedora Reporter: Jeff Layton <jlayton>
Component: nfs-utilsAssignee: Jeff Layton <jlayton>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 11CC: staubach, steved
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: cthon09
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-06-11 13:28:42 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Layton 2009-02-21 13:54:40 EST
Problem in a nutshell:

[root@redhat-11 cthon04]# mount -t nfs  -o vers=3 redhat-2:/server /mnt/cthon/
[root@redhat-11 cthon04]# umount -v /mnt/cthon
umount.nfs: Server failed to unmount ''
redhat-2:/server umounted


[root@redhat-11 cthon04]# mount -t nfs redhat-2:/server /mnt/cthon/
[root@redhat-11 cthon04]# umount -v /mnt/cthon
umount.nfs: trying prog 100005 vers 3 prot UDP port 797
redhat-2:/server umounted

...so we get an error message when unmounting if the mount was done with vers= option set. If it's not set, then we don't get an error.
Comment 1 Bug Zapper 2009-06-09 07:34:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 2 Steve Dickson 2009-06-11 13:28:42 EDT
This has been fixed in nfs-utils-1.2.0-3