Bug 489988

Summary: glx issues on i855
Product: [Fedora] Fedora Reporter: Mark Watts <m.watts>
Component: xorg-x11-drv-intelAssignee: Jonathan Blandford <jrb>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 11CC: ajax, andreas.petzold, ddumas, diegoe, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-23 08:07:25 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
glxinfo output
none
xorg log none

Description Mark Watts 2009-03-12 15:17:08 EDT
Hardware:
http://www.smolts.org/client/show/pub_147a1a2f-5adb-4d82-8a2a-fdd35783929b

Attempting to follow:
https://fedoraproject.org/wiki/QA:Testcase_intelvideo_glx

Initial Compiz test: "Unable to enable desktop effects"

$ glxinfo | grep direct
Direct Rendering: Yes

Running glxgears give me the following effect:
http://www.linux-corner.info/glxgears.jpg

Stopping glxgears and then re-trying the Compiz test now works (!)
Cube rotation and wobbly windows work smoothly.
glxgears pauses while cube rotation (via mouse) is in effect.
Comment 1 Mark Watts 2009-03-12 15:17:38 EDT
Created attachment 334996 [details]
glxinfo output
Comment 2 Mark Watts 2009-03-12 15:18:04 EDT
Created attachment 334997 [details]
xorg log
Comment 3 Diego Escalante Urrelo 2009-04-15 16:51:12 EDT
Hey Mark, is this the same as https://bugzilla.redhat.com/show_bug.cgi?id=490366 ?
Comment 4 Mark Watts 2009-04-16 05:09:30 EDT
I get the same horizontal banding, but not the vertical lines.
Comment 5 Bug Zapper 2009-06-09 08:11:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matěj Cepl 2009-11-05 13:23:09 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 8 Diego Escalante Urrelo 2009-11-23 10:08:08 EST
Hey. Just to confirm this is still present in Fedora 12, I opened an upstream bug:
  https://bugs.freedesktop.org/show_bug.cgi?id=24140
Comment 9 Diego Escalante Urrelo 2009-11-23 10:09:15 EST
Oops, sorry I confused bugs. Can't confirm on F12.
Comment 10 Mark Watts 2009-11-23 10:20:02 EST
Just to confirm, the issues I reported originally are not present on the same hardware running Fedora 12 release.