Bug 490550

Summary: CS 8.0 Alpha -- PKIConsole doesn't come up
Product: [Community] Dogtag Certificate System Reporter: Sean Veale <sean.veale>
Component: ESCAssignee: Deon Ballard <dlackey>
Status: CLOSED NOTABUG QA Contact: Chandrasekar Kannan <ckannan>
Severity: urgent Docs Contact:
Priority: urgent    
Version: unspecifiedCC: alee, awnuk, benl, bob.lord, cfu, dlackey, jeff.broitman, jmagne
Target Milestone: ---Keywords: TechPreview
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-26 12:06:12 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 443788    
Attachments:
Description Flags
Ca install log
none
Strace of the Java command for PKICONSOLE
none
Port definition none

Description Sean Veale 2009-03-16 18:53:11 EDT
Description of problem:
When starting pkiconsole for a subsystem (like the ca) the login and/or main window never appears.  The console appears to be dying silently. 

Version-Release number of selected component (if applicable):

CS 8.0 ALpha

How reproducible:
Always

Steps to Reproduce:
1. Start the console with a correct path, port and subsystem. 
2.
3.
  
Actual results:
Login and then console start.. 

Expected results:
nothing appears to happen. System process the command for a few seconds then the shell prompt returns.

Additional info:
I know the console is installed because it will give me a correct error message when I try to start an unrecognized subsystem.
Comment 1 Chandrasekar Kannan 2009-03-19 15:02:23 EDT
can you paste here the full command line you are using to launch pkiconsole with details on the port number ..?
Comment 2 Chandrasekar Kannan 2009-03-19 15:04:11 EDT
can you attach this log file to the bug or the mailing list - /var/log/pki-ca-install.log ?
Comment 3 Jeff Broitman 2009-03-19 15:18:06 EDT
Created attachment 335919 [details]
Ca install log
Comment 4 Jeff Broitman 2009-03-19 15:19:09 EDT
The startup is pkiconsole https://codeblue:9443/ca  ...using the FQDN doesn't make a difference.

-jzb
Comment 5 Chandrasekar Kannan 2009-03-19 15:20:52 EDT
try this...

 pkiconsole https://hostname:9445/ca
Comment 6 Jeff Broitman 2009-03-19 15:21:20 EDT
Created attachment 335922 [details]
Strace of the Java command for PKICONSOLE

I edited the pkiconsole script and added strace before the java command.  Attached is the output from this trial.
Comment 7 Jeff Broitman 2009-03-19 15:23:03 EDT
The 9445 worked.  I wasn't aware of the 9445 port, I've seen and used 9443 and 9444.  Where did I miss this 9445 port being defined or configured?

-jzb
Comment 8 Chandrasekar Kannan 2009-03-19 15:38:59 EDT
Created attachment 335927 [details]
Port definition
Comment 9 Chandrasekar Kannan 2009-03-19 15:39:35 EDT
I need to confirm with our doc writer to see if the above definitions are already documented or not.
Comment 10 Deon Ballard 2009-03-19 16:11:14 EDT
There are a couple of places this is mentioned specifically in the admin guide. For example:
*  The default instance information, which lists the default directories, etc., for each subsystem. http://elladeon.fedorapeople.org/RHCS/8.0/admin/ConfigFiles.html#default.ca.settings
* The "configuring ports" section:
http://elladeon.fedorapeople.org/RHCS/8.0/admin/Administration_Guide-Administrative_Basics-Ports.html

All of the examples, etc. have been updated with the new port numbers. 

This is also mentioned in the install guide, which mentions the default instance information and has information on using pkicreate to create an instance with a single SSL Port or separated ports (http://elladeon.fedorapeople.org/RHCS/8.0/install/AdditionalInstallOptions.html#Installation_and_Configuration-Creating_Additional_Subsystem_Instances) and in the agent guide for how to access agent services (http://elladeon.fedorapeople.org/RHCS/8.0/agent/Agent_Services-Accessing_Agent_Services.html).

If you didn't already know about port separation, though, it is easy to miss it in the docs. I'll expand the mention in the release notes to include the list of default port numbers and how they've changed and mention how that affects opening the console, and I'll do the same in the install guide. For the admin guide, I'll include the list of defaults in the intro to the "changing ports" section, and make it more obvious in the section on CS interfaces at http://elladeon.fedorapeople.org/RHCS/8.0/admin/Admin_Console.html.
Comment 11 Jeff Broitman 2009-03-26 09:28:02 EDT
This item should be considered solved.