Bug 492176

Summary: Multihead spanning problems
Product: [Fedora] Fedora Reporter: David Nalley <david>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: airlied, ajax, bskeggs, gene-redhat
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-03-25 21:16:32 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description David Nalley 2009-03-25 14:29:55 EDT
Description of problem: non-mirroring multihead fails.


Version-Release number of selected component (if applicable): Using the nouveau test livecd


How reproducible: Every Time


Steps to Reproduce:
1.Start gnome-display-properties
2.Uncheck mirror screens
3.Click apply
4.Reel in horror from the error message stating: 
required virtual size does not fit available size: requested=(3360, 1050), minimum=(320, 200), maximum=(1680, 1680)
  
Actual results: Multihead is unable to do anything other than mirror.


Expected results: Multihead should give 3360 worth of desktop. 


Additional info:
Smolt profile
http://www.smolts.org/client/show/pub_92c624c5-0cd1-4e95-88d4-e62b21702532

[liveuser@localhost ~]$ xrandr
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 1680 x 1680
LVDS-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050      60.0*+   50.0  
VGA-1 disconnected (normal left inverted right x axis y axis)
DVI-2 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050      60.0*+   59.9  
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     59.9  
   720x400        70.1
Comment 1 Gene Stuckey 2009-03-25 17:41:48 EDT
I also see the same error message, although with different sizes:

required virtual size does not fit available size: requested=(2720, 1024),
minimum=(320,200), maximum=(1440, 1440)

Smolt:
  http://www.smolts.org/client/show/pub_cd9ee5b7-022f-4a39-a281-4bd9c1594c27

xrandr:
Screen 0: minimum 320 x 200, current 1440 x 1024, maximum 1440 x 1440
LVDS-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
  1440x900       60.0*+
VGA-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
  1280x1024      60.0*+   75.0     60.0*
  1152x864       75.0
  1024x768       75.0     60.0
  800x600        75.0     60.3
  640x480        75.0     59.9
  720x400        70.1
DVI-2 disconnected (normal left inverted right x axis y axis)
Comment 2 Ben Skeggs 2009-03-25 21:15:28 EDT
Unfortunately this is the expected behaviour currently.  Due to shortcomings in our memory manager for this release we won't be able to resize the framebuffer from it's initial configuration.

However, if you configure a non-cloned layout in xorg.conf as described at http://wiki.debian.org/XStrikeForce/HowToRandR12 you should be able to make this work.
Comment 3 Ben Skeggs 2009-03-25 21:16:32 EDT

*** This bug has been marked as a duplicate of bug 487356 ***